Picapport web interface error when navigating folders

6 views
Skip to first unread message

Yasmeen Shabana

unread,
Nov 24, 2022, 4:40:03 AM11/24/22
to PicApport
Hello,

I have a problem appeared recently. so after few weeks of adding all my photo folders to Picapport, everything was working fine but 3 days ago I started to get an error saying "Error loading page" when I go to the web interface and navigate to folder then click on any of the folders that existing there (see screenshot of the folders)

it was not possible to take screenshot of the error itself because it disappears very fast. I looked in the log file but cannot see related errors there. I attach it here as well.

I am using windows 11, picapport for windows, java is installed and updated today.

what I have tried in order:
1st- changed the port, made sure the port is available for picapport and the server is running
2nd-  removed all folders and add them one by one leaving enough time in between to fully load the folders
3rd- uninstalled and re-installed java and picapport.
4th- restored a copy of windows when picapport was working.

I have been trying everything for 3 days, and nothing is fixing the error 

Log and screenshots at the end

appreciate any help
yasmeen

folders.jpg



******************************************************************************
C:\Users\Yasmeen\.picapport\logfiles\picapport.002 created at 2022-11-23 11:46:02
allowOutputOnSystemOut=true
******************************************************************************
Copyright (c) 1997-2022 Contecon Software GmbH. All rights reserved.
2022-11-23 11:46:02
Tracelevel: ERROR
VER  @ 11:46:02.183 PicApport Version 10.4 from 06.04.2022 loaded.
VER  @ 11:46:02.184 de.contecon.picapport.PicApport.Version=V10.4.0 06.04.2022
VER  @ 11:46:02.184 java.runtime.version: 17.0.5+8-LTS
VER  @ 11:46:02.185 java.version: 17.0.5
VER  @ 11:46:02.185 java.vm.version: 17.0.5+8-LTS
VER  @ 11:46:02.185 java.vm.vendor: Microsoft
VER  @ 11:46:02.186 java.vm.name: OpenJDK 64-Bit Server VM
VER  @ 11:46:02.186 java.specification.version: 17
VER  @ 11:46:02.186 java.vm.specification.version: 17
VER  @ 11:46:02.188 java.class.path: picapport.exe
VER  @ 11:46:02.188 os.name: Windows 11
VER  @ 11:46:02.188 os.version: 10.0
VER  @ 11:46:02.188 os.arch: amd64
VER  @ 11:46:02.189 file.separator: \
VER  @ 11:46:02.189 path.separator: ;
VER  @ 11:46:02.189 user.dir: C:\Program Files (x86)\PicApport
VER  @ 11:46:02.189 user.home: C:\Users\Yasmeen
VER  @ 11:46:02.190 user.name: yasme
MSG  @ 11:46:02.190 SystemProperty: log.console.level not set. PicApport sets default to:WARNING (OrientDB configuration)
MSG  @ 11:46:02.190 SystemProperty: storage.diskCache.bufferSize not set. PicApport sets default to:512 (OrientDB configuration)
MSG  @ 11:46:02.190 SystemProperty: com.sun.xml.bind.v2.bytecode.ClassTailor.noOptimize not set. PicApport sets default to:true (JAXB Java 17 Support)
MSG  @ 11:46:02.191 SystemProperty: log4j2.formatMsgNoLookups not set. PicApport sets default to:true (CVE-2021-44228: Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints.)
MSG  @ 11:46:02.191 java.runtime totalMemory=536mb maxMemory=2147mb freeMemory=523mb processors=8
MSG  @ 11:46:02.222 java.runtime.argument: -Xms512m
MSG  @ 11:46:02.222 java.runtime.argument: -Xmx2048m
MSG  @ 11:46:02.222 java.runtime.argument: -Djna.nosys=true
MSG  @ 11:46:02.223 PicApport home=C:\Users\Yasmeen\.picapport
MSG  @ 11:46:02.223 PicApport logging to C:\Users\Yasmeen\.picapport\logfiles
MSG  @ 11:46:02.223 org.eclipse.jetty.LEVEL set to OFF
MSG  @ 11:46:02.224 Loading config File: C:\Users\Yasmeen\.picapport\picapport.properties
MSG  @ 11:46:02.269 PicApportProperties.client.video.types.json[0].ext=.mp4 mime=video/mp4
MSG  @ 11:46:02.269 PicApportProperties.client.video.types.json[1].ext=.m4v mime=video/mp4
MSG  @ 11:46:02.270 PicApportProperties.client.video.types.json[2].ext=.ogv mime=video/ogg
MSG  @ 11:46:02.270 PicApportProperties.client.video.types.json[3].ext=.webm mime=video/webm
MSG  @ 11:46:02.270 PicApportProperties.client.video.types.json[4].ext=.mov mime=video/quicktime
MSG  @ 11:46:02.270 PicApportProperties.client.video.types.json[5].ext=.qt mime=video/quicktime
MSG  @ 11:46:02.278 Init: picApportHome=C:\Users\Yasmeen\.picapport
MSG  @ 11:46:02.280 Init: gui.enabled=true
MSG  @ 11:46:02.280 Init: gui.hideintray=true
MSG  @ 11:46:02.280 Init: robot.root.0.id=Denmark
MSG  @ 11:46:02.280 Init: robot.root.0.isuploadroot=true
MSG  @ 11:46:02.281 Init: robot.root.0.path=I:\Denmark
MSG  @ 11:46:02.281 Init: robot.root.1.id=Egypt
MSG  @ 11:46:02.281 Init: robot.root.1.path=I:\Egypt
MSG  @ 11:46:02.282 Init: server.demomode=false
MSG  @ 11:46:02.282 Init: server.port=6021
MSG  @ 11:46:02.282 Init: server.ssl=false
MSG  @ 11:46:02.282 Init: webapi.enabled=false
MSG  @ 11:46:02.300 PicApportRestartHandler.init: Restart activated for pid:8940 command=C:\Program Files\Microsoft\jdk-17.0.5.8-hotspot\bin\java.exe
MSG  @ 11:46:02.461 FuzzySearchManager.init.phoneticEncoder: de.contecon.picapport.fuzzysearch.PaPhonDoubleMetaphoneV1.0
MSG  @ 11:46:02.484 FuzzySearchManager No Thesaurus-Files (*.pathes) found in C:\Users\Yasmeen\.picapport\thesaurus
MSG  @ 11:46:02.511 Initialize user database in C:\Users\Yasmeen\.picapport\users
MSG  @ 11:46:02.514 Load users from C:\Users\Yasmeen\.picapport\users
MSG  @ 11:46:02.549 Initializing User Management: CcUser2  V1.6 build:2018.06.28-##CC_BUILD##
MSG  @ 11:46:03.829 User Management: Initializing/creating UniqueId store in: C:\Users\Yasmeen\.picapport\users\vars\id_counter
MSG  @ 11:46:03.841 User Management: DB-Version updated to: 8.06
MSG  @ 11:46:03.855 Search for plugins in C:\Users\Yasmeen\.picapport\plugins
MSG  @ 11:46:03.861 Plugin loaded: PicApport geojson plugin 1.0 (c) 2019 Contecon Software GmbH .geojson application/geo+json (hideSubstitutes=true) implements IOtherFileFormat:de.contecon.picapport.plugins.geojson.GeoJsonPlugin
MSG  @ 11:46:03.920 Queries loaded: 0
MSG  @ 11:46:03.924 Designs loaded: 0 from C:\Users\Yasmeen\.picapport\designs
MSG  @ 11:46:04.155 PicApportDBService.startDatabase:embedded:C:/Users/Yasmeen/.picapport/db (C:\Users\Yasmeen\.picapport\db\db_3_0_39)
MSG  @ 11:46:06.579 PicApportDBService.startDatabase: Database version=3_0_39
MSG  @ 11:46:19.130 FileSystemMonitor is active.
MSG  @ 11:46:31.019 PicApport.startGui.javaFxIsAvailable=false isGuiEnabled=true
MSG  @ 11:46:32.493 DbWrapper.getAlternateDatePattern: M/d/yyyy = MM/dd/yyyy
****** PicApport starts a new day at 11/23/2022 11:46:41
MSG  @ 11:49:25.798 PicApport.shutdown initiated...
MSG  @ 11:49:26.184 PicApport.shutdown completed.
MSG  @ 11:49:26.184 PicApport.exit: Exitcode=0
MSG  @ 11:49:26.197 User Management has been successfully shut down.

E. Schreiner

unread,
Nov 24, 2022, 4:47:30 AM11/24/22
to PicApport
does the problem only occur when you click on the folder icon? What happens when you enter a full text query or open the about page?
What browser are you using?

Yasmeen Shabana

unread,
Nov 25, 2022, 3:26:17 AM11/25/22
to PicApport
hi,

thanks for your reply. i tried both google chrome and edge with no success. the problem occurs when i click on the oflder and when i use the dir command. other pages work fine. after long day of investigation, it turns out it is java / JNA problem. for some reason picapport works only with certain versions and when my java auto updates, picaaport stops working. I found out adding this line "-Djna.nosys=true" to this file "picapport.l4j.ini" makes picapport work regardless of the version. or at least this is my understanding. for now this is working fine. I do not have enough knowledge about how picapport is developed, but with help from internet it seems to have solved the issue :) 

thanks 
yasmeen 

Reply all
Reply to author
Forward
0 new messages