PicApport unter Windows startet nicht

35 views
Skip to first unread message

Benni

unread,
Sep 26, 2022, 3:02:54 AM9/26/22
to PicApport
 Hallo.

Ich versuche grade verzweifelt PicApport 10.4 auf einem WindowsPC zum Laufen zu bekommen.

Das Setup läuft ohne Fehler durch, aber wenn ich dann versuche PicApport zu starten, dann sehe ich ein paar Sekunden den SplashScreen und dann verschwindet dieser, ohne dass etwas passiert. Im ProcessManager ist kein PicApport zu finden, im Ereignisprotokoll von Windows ist auch nichts zu sehen. Restart und De- und Neu-Installation hat auch nichts gebracht.

Was mache ich falsch?

Beste Grüße
Benjamin Stehle  

Christian Karl

unread,
Sep 26, 2022, 5:19:08 AM9/26/22
to PicApport
Hallo Benjamin,
PicApport läuft im Webbrowser.
Starte mal einen und rufe die Adresse vom Server auf. Also localhost oder, wenn Du nicht an diesem Computer sitzt, die ip vom Server. Mobile-Telefon oder Tablet geht auch als Client!
Was wird da angezeigt?

Benni

unread,
Sep 26, 2022, 5:42:53 AM9/26/22
to PicApport
Wie zu erwarten war kommt "Die Webseite ist nicht erreichbar". Dass PicApport im Browser läuft,  ist mir klar. Aber ich kann ja den PicApport-Server gar nicht starten. Wenn der Server-Prozess nicht läuft kann ich auch nicht auf das Frontend im Browser zugreifen ;-)

Ich habe zwischenzeitlich auch sicherheitshalber Java nochmal aktualisiert.
Seltsam ist auch, dass ich keinerlei Start-Logfiles oder ähnliches finden kann.

Benni

unread,
Sep 29, 2022, 5:03:39 AM9/29/22
to PicApport
Gibt es hierzu gar keine Idee von Seiten PicApport-Support? 

Easys web-de

unread,
Oct 5, 2022, 4:06:02 AM10/5/22
to PicApport
bei mir hat er ohne problem gestartet, ist dein serverport evtl. belegt ?
schau mal unten rechts in der statuszeile der server-app was da für ein port steht.

dann teste mal den port lokal auf deinem server mit der 127.0.0.1:port mittels browser.

Benni

unread,
Nov 18, 2022, 7:06:55 AM11/18/22
to PicApport
Ich bin echt verzweifelt - ich liebe PicApport, aber ich bekomme es einfach nicht hin.
Lieber Support - BITTE meldet euch. Ich weiß nicht, wo ich den Fehler suchen soll.....

E. Schreiner

unread,
Nov 18, 2022, 7:46:50 AM11/18/22
to PicApport
... Schau mal in die Logdateien in .picapport/Logfiles rein.

E. Schreiner

unread,
Nov 18, 2022, 8:22:00 AM11/18/22
to PicApport
Bitte auch den dort angegebenen Test durchführen.
Ich gehe allerdings davon aus das Du gemäß Deiner Logdatei schlichtweg zu wenig Hauptspeicher (konfiguriert hast) hast: MSG  @ 13:52:09.598 java.runtime totalMemory=132mb maxMemory=1073mb freeMemory=117mb processors=6
MSG  @ 13:52:09.612 java.runtime.argument: -Xmx1024m
Ich empfehle mindestens 4gig wenn Du die KI nutzen willst......

Benni

unread,
Nov 21, 2022, 5:42:18 AM11/21/22
to PicApport
 Hallo.

Der Pfad ".picapport" war mir nicht bekannt, daher hatte ich dieses Logfile nicht herangezogen.
Tatsächlich wird hier ein Fehler protokolliert:
ERROR@ 11:37:44.525 Exception Error PicApport.main: java.lang.Error:     There is an incompatible JNA native library installed on this system  Expected: 5.2.0  Found:    4.0.1

Wie und wo kann ich diese Bibliothek aktualisieren?
Ein einfaches "Install" finde ich online irgendwie nicht... Wohlgemerkt handelt es sich um einen Windows-Rechner...

Danke für einen Tip

Benjamin  

Benni

unread,
Nov 21, 2022, 6:38:45 AM11/21/22
to PicApport
Ich habe das Problem nun gelöst bekommen, indem ich im Installationspfad von PicApport die Datei picapport.l4j.ini angepasst habe und den Parameter  "-Djna.nosys=true" hinzugefügt habe. Dadurch wird die JNA-lib immer aus der JAR-Datei extrahiert und eventuell vorhandene Versionen auf dem Computer werden ignoriert.
Reply all
Reply to author
Forward
0 new messages