Re: [perl #34178] [PATCH][MSWin32] Add gpm linkage and minor cleanup

1 view
Skip to first unread message

Leopold Toetsch

unread,
Feb 21, 2005, 5:54:46 AM2/21/05
to perl6-i...@perl.org
Ron Blaschke <parrotbug...@parrotcode.org> wrote:

> - adds correct linkage for gpm
> Some tests fail, though
> t\pmc\bigint.t 12 3072 21 12 57.14% 5-10 13-15 18 20-21

Is there any indication what's going wrong?

Thanks, applied.
leo

Ron Blaschke

unread,
Feb 21, 2005, 1:48:52 PM2/21/05
to Leopold Toetsch, perl6-i...@perl.org

Not yet, but I'm looking into it. Might as well be my own fault, not
completely sure I got gmp built right. I'll keep you posted.

Here's a simple test that fails.

>type bigint_fail.pasm
new P0, .BigInt
print "ok 0\n"
set P0, "1230000000000"
print "ok 1\n"
end

>parrot bigint_fail.pasm
ok 0

>echo %ERRORLEVEL%
-1073741819

Ron


Ron Blaschke

unread,
Mar 6, 2005, 10:01:53 AM3/6/05
to Leopold Toetsch, perl6-i...@perl.org
Ron Blaschke wrote:
> Leopold Toetsch wrote:
>> Ron Blaschke <parrotbug...@parrotcode.org> wrote:

>>> - adds correct linkage for gpm
>>> Some tests fail, though
>>> t\pmc\bigint.t 12 3072 21 12 57.14% 5-10 13-15 18 20-21

>> Is there any indication what's going wrong?
> Not yet, but I'm looking into it. Might as well be my own fault, not
> completely sure I got gmp built right. I'll keep you posted.

It really was a GMP build failure. Seem to have got it right, now.

t\pmc\bigint....ok
All tests successful.
Files=1, Tests=21, 3 wallclock secs ( 0.00 cusr + 0.00 csys = 0.00 CPU)

Ron


Reply all
Reply to author
Forward
0 new messages