What linux versions are supported?

29 views
Skip to first unread message

Ryan Schwartz

unread,
Jun 3, 2014, 12:03:13 PM6/3/14
to pdfne...@googlegroups.com
Hello,

I can't seem to find documentation that says what versions/releases of linux and/ruby are supported?

We're on CentOS 6.5 and I cannot use the pre-built binaries because they are linked against GLIBC_2.14.

I cannot build the wrappers (on any version of ruby, I've tried three) because of numerous swig errors: https://gist.github.com/ryanschwartz/99427214902b238b06e0

We're stuck at this point, hopefully someone else has information on what OS/ruby this should work with.

Aaron

unread,
Jun 3, 2014, 1:48:50 PM6/3/14
to pdfne...@googlegroups.com
Hello Ryan,

Thanks for letting us know that you're seeing this behaviour. 

> I can't seem to find documentation that says what versions/releases of linux and/ruby are supported?

The SDK should run on most modern distributions.


> We're on CentOS 6.5 and I cannot use the pre-built binaries because they are linked against GLIBC_2.14.

Could you kindly provide further detail?  What problems are you seeing?

In terms of RedHat-derived distributions, we tested v6.2.1 against Fedora Core.  I will try it out against CentOS 6.5 to see if I can reproduce the errors you're seeing.

Meanwhile, you might want to try out one of the "nightly" builds at http://www.pdftron.com/nightly/, built from our experimental branch.  These builds have reduced the visibility of GLIBC symbols, so you might have an easier time of linking.  (You should be able to drop in the new PDFNet.so into the pre-built wrappers and run the Ruby samples.)

Reply all
Reply to author
Forward
0 new messages