Bug#719949: pcmanx-gtk2: New upstream version 1.2 available (2013-02-21)

12 views
Skip to first unread message

Anthony Fok

unread,
Aug 17, 2013, 1:12:06 AM8/17/13
to Debian Bug Tracking System
Package: pcmanx-gtk2
Version: 1.1-2
Severity: wishlist

There is a new upstream release of pcmanx-gtk2, version 1.2,
available for download:

https://code.google.com/p/pcmanx-gtk2/downloads/list

New features:

* Use consistent naming: PCManX
* Allow users to search selected text through Web search engine
* Handle malformed URL properly
* Usability enhancement for Unity desktop environment
* Add new interface to show and hide toolbar
* Remember maximized state
* Improve the performance of cairo caret

Bug fixes:

* SegFault when $LANG is not set
* Replace system() with execlp() for sake of security
* Use g_spawn_async() instead of fork()/execlp() to prevent crash
* Build failure when configured as --disable-docklet
* Status bar appears in simple mode
* FcFontSort() should no longer use NULL' as the value of result'
* Change "class" and "name" hints for a window.
* Add "StartupNotify=true"
* Fix the invisible cursor issue
* Fix a bug that NancyBot incorrect parsing the input string on 64bit OS.

As of today, the latest version in Debian (and Ubuntu)
is pcmanx-gtk2 (1.1-2), uploaded in May 2012.

Cheers,

Anthony Fok



-- System Information:
Debian Release: wheezy/sid
APT prefers raring-updates
APT policy: (500, 'raring-updates'), (500, 'raring-security'), (500,
'raring'), (100, 'raring-backports')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.8.0-27-generic (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages pcmanx-gtk2 depends on:
ii libc6 2.17-0ubuntu5
ii libfontconfig1 2.10.2-0ubuntu2
ii libfreetype6 2.4.11-0ubuntu1
ii libgdk-pixbuf2.0-0 2.28.0-0ubuntu1
ii libglib2.0-0 2.36.0-1ubuntu2
ii libgtk2.0-0 2.24.17-0ubuntu2
ii libltdl7 2.4.2-1.2ubuntu1
ii libnotify4 0.7.5-2
ii libpango1.0-0 1.32.5-0ubuntu1
ii libstdc++6 4.7.3-1ubuntu1
ii libx11-6 2:1.5.0-1ubuntu1.1
ii libxft2 2.3.1-1

pcmanx-gtk2 recommends no packages.

pcmanx-gtk2 suggests no packages.

Emfox Zhou

unread,
Aug 17, 2013, 8:35:28 AM8/17/13
to Anthony Fok, Debian Bug Tracking System

Oh, I should have noticed the new release earlier...

I'll probably update it in several weeks or one month, 'cause I'm a little busy recently.

Debian Bug Tracking System

unread,
Feb 24, 2016, 10:22:57 AM2/24/16
to Emfox Zhou
Version: 1.2-1
Reply all
Reply to author
Forward
0 new messages