Clustered ApplicationScoped beans and Singleton EJB not work as document stated

12 views
Skip to first unread message

Cidy Long

unread,
Aug 23, 2021, 2:26:26 AM8/23/21
to Payara Forum
I spent about a week to test Payara 5.2021.5 Clustered ApplicationScoped or Singleton EJB features.

Environment: 
Platform: Payara community edition 5.2021.5, 
OS: Centos 8
Machines (nodes): two Intels
Payara server instances three: DAS, Server1, Server2


Tested:

1. Create a maven project by using NetBeans 12.4, load examples java class and GlassFish-ejb-jar.xml
2. Modify and confirm runtime environment and dependency as Payara 5.2021.5 with pom.xml 
3. Build EJB.jar
4. Deploy EJB.jar to Payara Domain without target (import!)

There are interesting result:
1. I tried deploy the EJB.jar into domain, only couple of times I saw the 

--------Distributed Obj Created: Payara/ejb/singleton/EJBClusterModule_EJBClusterModule_dateTimeServImpl_EJBModule-EJB-dateTimeServImpl106796718079117640, service=hz:impl:mapService---------- Distributed Object size: 47]]

in the server.log, don't see any thing recently days
2. There is document state how to access or lookup the Clustered ApplicationScoped beans or Singleton EJB at all, so what's for this features?
3. There is no way to check where is clustered beans in Hazelcast map at all. There are some Hazelcast maps in system level (payara-instance-map(for payara server instances), payara.micro.applications.store, payara.microprofile.config, payara.instance.store,) but there is no one to keep clustered Singleton EJB or applicationScoped beans
4. Tried to turn that simple EJB application into Java 9 compatible module by introduce module-info.java and recompile whole project. As there are @PostConstruct and @preDestory annotation, module has to requires annotations module and this module need ASM, tried to include ASM-Tree 7.3.1 (Payara 5.2021 provided) and compile successful. When deploy it into Payara domain, payara throws:

[Payara 5.2021.5] [WARNING] [NCLS-DEPLOYMENT-00009] [javax.enterprise.system.tools.deployment.common] [tid: _ThreadID=508 _ThreadName=admin-thread-pool::admin-listener(11)] [timeMillis: 1629695285354] [levelValue: 900] [[

  Failed to scan archive for annotations: {0}

java.lang.UnsupportedOperationException: This feature requires ASM6

That means, it is not tested at all.

One word In all. Any thing I missed? Or this feature is not ready be used? Or it is not my expected (Beans (ApplicationScoped bean or Singleton EJB) can be accessed by lookup from Hazelcast map instead of Context in cluster wide)?

Any one have this experience, please advise!

Appreciated!!

Reply all
Reply to author
Forward
0 new messages