passwordfile change in 5.2021.5?

22 views
Skip to first unread message

Mike Ryan

unread,
Aug 10, 2021, 11:18:54 AM8/10/21
to Payara Forum
Hi,

I use the following to deploy a war file, which has worked for years, and definitely works in 5.2021.4, but breaks in 5.2021.5:

asadmin --user my_user --passwordfile /path/to/.passwordfile --host my_host deploy --force=true /path/to/my_app.war

Works in 5.2021.4, but fails in 5.2021.5 with the following:

Unable to create a system terminal, creating a dumb terminal (enable debug logging for more information)
Authentication failed for user: my_user
(Usually, this means invalid user name and/or password)
Command deploy failed.

My .password file has the following format:

AS_ADMIN_PASSWORD=my_password

My first thought was maybe the format in the .password file has changed, but AS_ADMIN_USERPASSWORD and ADMIN_PASSWORD do not work either.

Everything is running on Java 11.

Any ideas?

Thanks,

Mike

Mike Ryan

unread,
Aug 19, 2021, 10:02:38 AM8/19/21
to Payara Forum
Looks like this was on my end, so nothing to see here, as far as Payara is concerned.

We run Payara in a cluster and after restarting the service a couple of times, the password issue went away. Specifically, it's working in 5.2021.6, but probably would've worked in 5.2021.5 as well had I tried the extra restart. The thing is, I restart the service in my environment script so wasn't expecting I'd need to do it again after the script completed. In our prod environment, no extra restart was necessary. 

-m

Reply all
Reply to author
Forward
0 new messages