QSY failed

8 views
Skip to first unread message

Keith Kaiser

unread,
Sep 11, 2022, 1:02:33 PMSep 11
to pat-users
This is an old problem I’m still having. When I launch PAT (pat https) I still can not connect to my rig. This has been a long time problem through 3 different computers so I hope someone has solved it.

Rig: Icom IC-7000
SignaLink USB: also runs all my other digital operations fldigi, wsjt-x, etc. without issue
Computer: M2 MacBook Air

Pat runs just fine in telnet mode, all the usual commands and connections work, but when I launch Pat it tries to connect to my rig but I get;

QSY failed: unable to get rig frequency: dial tcp 127.0.0.1:3060: connect: connection refused

Anyone have a suggest what to try next, or a solution, is this working for you?

Thanks

Keith, WA0̷TJT
Author: https://net-control.us
ARRL ARES Communicator Level 2, AEC for Platte Co. MO
KCHEART Radio Operator - St. Lukes Barry Road Hospital

Keith Kaiser

unread,
Sep 11, 2022, 1:33:32 PMSep 11
to pat-users
Well, as is usually the case I think I have an answer. In the pat config.json file I had rig as IC-7000 just as something new to try I changed it to 'Icom IC-7000' and now it appears to be connecting. At least I'm not getting the old error but I'm still not changing frequencies as I should and the RMS list dropdown is starting with LU4EGV-15 regardless of what mode is selected. so something isn't working. 

Your thoughts?

Keith Kaiser

unread,
Sep 11, 2022, 2:51:18 PMSep 11
to pat-users
The problem I'm having is with Hamlib, it looks like Pat is not finding it. Where is Pat looking for Hamlib on this machine, and how do I tell it where to look?
Reply all
Reply to author
Forward
0 new messages