debian package installation

39 views
Skip to first unread message

jpspoo...@gmail.com

unread,
Aug 18, 2022, 3:49:20 PMAug 18
to pat-users
I am running Linux Mint 20.3 on an i386 laptop; attempting to install pat (winlink).
lscpu gives: x86_64.
The debian package installation seems to go without a hitch, but the executable installed in /usr/local/bin always fails to run with:
bash:  /usr/local/bin/pat No such file or directory.

what am I doing wrong?

John NX2I

John Spoonhower

unread,
Aug 18, 2022, 5:09:11 PMAug 18
to pat-users
pat configure gives the same erro

--
You received this message because you are subscribed to the Google Groups "pat-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to pat-users+...@googlegroups.com.
To view this discussion on the web, visit https://groups.google.com/d/msgid/pat-users/85ac519f-c607-425e-b30f-8df93bedef14n%40googlegroups.com.

John Spoonhower

unread,
Aug 18, 2022, 5:14:32 PMAug 18
to pat-users
I should add that env shows that $PATH includes /usr/local/bin. Also multiple installs on raspberry pi do not have this problem.

Ed Fardos

unread,
Aug 18, 2022, 5:19:42 PMAug 18
to John Spoonhower, pat-users
I'm guessing the /usr/local/bin/pat is a broken symlink, or some left-over.  run "ls -al /usr/local/bin | grep pat" to see it.

run "rm /usr/local/bin/pat"  , that'll get rid of it.

I exploded the pat deb, and you'll find the pat executable at /usr/bin/pat.

The "/usr/local/bin" path is typically used if you compile software locally.

-craig
KM6LYW




./
./lib/
./lib/systemd/
./lib/systemd/system/
./lib/systemd/system/pat@.service
./usr/
./usr/bin/
./usr/bin/pat
./usr/share/
./usr/share/man/
./usr/share/man/man1/
./usr/share/man/man1/pat-configure.1.gz
./usr/share/man/man1/pat.1.gz
./usr/share/pat/
./usr/share/pat/ardopc/
./usr/share/pat/ardopc/ardop@.service
./usr/share/pat/ardopc/install-systemd-ardop-unit.bash
./usr/share/pat/ax25/
./usr/share/pat/ax25/README.systemd
./usr/share/pat/ax25/ax25.default
./usr/share/pat/ax25/ax25.service
./usr/share/pat/ax25/install-systemd-ax25-unit.bash
./usr/share/pat/ax25/mheardd.service
./usr/share/pat/ax25/soundmodem-example.conf
./usr/share/pat/bin/
./usr/share/pat/bin/axup
./usr/share/pat/rigctld/
./usr/share/pat/rigctld/install-systemd-rigctld-unit.bash
./usr/share/pat/rigctld/rigctld.default
./usr/share/pat/rigctld/rigctld.service

Martin Hebnes Pedersen

unread,
Aug 18, 2022, 5:42:41 PMAug 18
to jpspoo...@gmail.com, pat-users
Hi John,

You will get this error if you attempt to execute a binary compiled for a different architecture. You say you are attempting to run this on a i386 (32 bit) laptop, yet the output of lscpu suggests you are running on a 64 bit CPU.

1. What's the name of the deb you installed?
2. What's the output of: file /usr/local/bin/pat ?
3. What's the output of: uname -a ?

-- 
Martin

--

Martin Hebnes Pedersen

unread,
Aug 18, 2022, 6:00:46 PMAug 18
to Ed Fardos, John Spoonhower, pat-users
I second what Ed wrote.

John, it looks like you have some traces of a bad install from a custom build. Delete /usr/local/bin/pat and install the appropriate deb for your OS architecture (either i386 or amd64 depending on the output from uname -a).

Hope this sorts it out. If not, please share the answers to my questions in the provious email.

-- 
73 de LA5NTA / Martin

Martin Hebnes Pedersen

unread,
Aug 19, 2022, 2:42:07 AMAug 19
to John Spoonhower, pat-users
I'm glad it worked out :-)

-- 
73 de LA5NTA/Martin

fre. 19. aug. 2022, 00:12 skrev John Spoonhower <jpspoo...@gmail.com>:
Martin et al.,
all is well now.
Thanks,
john

On Thu, Aug 18, 2022 at 6:05 PM John Spoonhower <jpspoo...@gmail.com> wrote:
I thought I downloaded the correct file but here's the info you requested Martin:
1) pat_0.12.1_linux_i386.deb
2) /usr/bin/pat produces "bash:  /usr/bin/pat No such file or directory
3) Linux john-Latitude-D630 5.4.0-124-generic #140-Ubuntu SMP Thu Aug 4 02:23:37 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

I will try the amd64 download and bounce back
73 to all reponders

Ric Soard

unread,
Aug 19, 2022, 10:55:40 PMAug 19
to pat-users
I am having the same problem installing on the pi.  I used the pi package, armhf, I’ve tried both 0.12.0 and 0.12.1. Pat is in the user/bin directory and is executable. Any help would be appreciated. 

73
Ric AJ6UE 

Ric Soard

unread,
Aug 19, 2022, 11:01:56 PMAug 19
to pat-users
I suspect I’ll need to build from source as I’m using arm64. 

73
Aj6ue 

Martin Hebnes Pedersen

unread,
Aug 20, 2022, 8:59:43 AMAug 20
to Ric Soard, pat-users

Hi Ric,

We will start including arm64 deb packages in the next release (v0.13.0) which I am currently working on getting out. Probably this weekend.

If you’re very eager to get Pat running asap, you could build from source. Instructions can be found here: https://github.com/la5nta/pat/wiki/Building-from-source.

— 
73 de LA5NTA / Martin

RICHARD SOARD

unread,
Aug 20, 2022, 8:06:50 PMAug 20
to Martin Hebnes Pedersen, pat-users
Thank you. Seems to work. 

Sent from my iPhone

On Aug 20, 2022, at 5:59 AM, Martin Hebnes Pedersen <martin.h...@gmail.com> wrote:



Cal Brabandt

unread,
Aug 21, 2022, 1:35:08 AMAug 21
to pat-users
Ric,

Or you could try Luke's arm64 binary:

It's linked a couple of paragraphs down here:

and a Pat basic howto sequel post from Luke here:

His binary works on both my Pinebook Pro (running Manjaro) and my Pinephone (running Mobian), which are both arm64 machines. As I recall, Pt was easy to build on my Pinebook Pro too.

-Cal -- AD8Q

Martin Hebnes Pedersen

unread,
Aug 21, 2022, 5:15:02 AMAug 21
to pat-users
FYI - I’ve updated the release (v0.13.0) with a linux/arm64 tarball for anyone running arm64 without a deb package manager :)

— 
73 de LA5NTA / Martin
Reply all
Reply to author
Forward
0 new messages