analysis does not get over initial ML tree estimation

51 views
Skip to first unread message

Saskia Wutke

unread,
Apr 22, 2020, 6:34:46 PM4/22/20
to PartitionFinder
Hey,

I am running PF2 on a fairly large nucleotide dataset (456 taxa, ~60kb) but it seems to get stuck during the first part of the analysis (with raxml). After more than a day it is still at (log file attached):

INFO     | 2020-04-21 14:04:42,789 | raxml      | Using a separate GTR+G model for each data block

When opening the  analysis/start_tree/RAxML_info.fastTREE, it randomly ends like this (file attached): 

Partition: 674
Alignment Patterns: 102
Name: Subset675
DataType: DNA
Substitution Matrix: GTR



Partition: 675
Al

This stopped at the same time (2020-04-21 14:04) as the log file shortly after the analysis was started and since then nothing has happened. 

To me that looks like it got stuck somehow. At first I thought that this partition has a problem but when I ran it again it stopped at another Partition 589. 
With a different partitioning scheme on the same dataset I had a similar problem that it did not get over this step ("Using a separate GTR+G model for each data block") for more than 4 days (but here the analysis/start_tree/RAxML_info.fastTREE file stopped at: 
Partion 366 number of Cats: 1
Partion 367 number of Cats: 1)

Could it be a problem with raxml? I cannot find why it stops at these random steps. 

I hope this is not too confusing and that someone else might be more experienced with PF than me and could point me to a solution. 

Best,
Saskia







log.txt
RAxML_info.fastTREE
partition_finder.cfg

Saskia Wutke

unread,
Apr 23, 2020, 2:16:00 AM4/23/20
to PartitionFinder
Sorry, forgot to add that I am running it on a Linux supercombuter as a batch job. The exact command in the batch script was this: 

python2 /users/swutke/partitionfinder/PartitionFinder.py -p 24 --raxml --rcluster-max 100 --quick swsc-entropy/

Thanks,
Saskia 

Conrad Williams

unread,
May 11, 2020, 7:48:02 PM5/11/20
to PartitionFinder
Hi,

New to this Google Group, but I was running into the same issue and think I found a fix that worked for me and might work for you.
Did you clone PartitonFinder from GitHub? I had done that and ran into this issue, but using the latest release (v 2.1.1 from 2016) seems to have fixed the issue for me. I'm also running things in a very similar environment to you (a CentOS Linux cluster), so hopefully this helps you, too.

Best,
Conrad
Reply all
Reply to author
Forward
0 new messages