Newbie question

25 views
Skip to first unread message

John Kuhn

unread,
May 12, 2022, 3:16:10 PMMay 12
to PAL 6502 computer
I received my PAL-1 kit yesterday, and built it up. I am able to load programs through the keypad with no problem. If I go back and check the contents of RAM, everything is loaded as expected. When I enter the address to run the program and hit GO, the display blanks and never returns. The only way to get the display back is to hit the RS button. I have tried simple programs that I wrote, and simple programs that others have written, like adding two numbers, and all do the same thing. I have tried locating the program at different RAM locations with no luck. I have visually inspected all solder joints, and pins on the IC's, and all look good.

Any thoughts?

John

Magnus Olsson

unread,
May 12, 2022, 4:34:49 PMMay 12
to PAL 6502 computer
Did you remember to set the interrupt vectors at addresses 17FA, 17FB and 17FE, 17FF? They should be
17FA 00
17FB 1C

17FE 00
17FC 1C

If your program ends with a BRK instruction (00) and you haven't set these vectors, the computer will very probably hang. This could be what you're seeing.

Magnus Olsson

unread,
May 12, 2022, 4:35:54 PMMay 12
to PAL 6502 computer
You could also try entering the program on page 6 of the PAL-1 manual (not the KIM-1 manual). That program counts up on the display so the display should show digits all the time it's running.

John Kuhn

unread,
May 12, 2022, 9:26:31 PMMay 12
to PAL 6502 computer
Problem solved. I need to read the manual.

Thanks.

--
You received this message because you are subscribed to a topic in the Google Groups "PAL 6502 computer" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/pal6502/a9owBhGJDmw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to pal6502+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/pal6502/024f707c-2c16-4ba0-81f3-28ade999fb5fn%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hendrik-Jan Megens

unread,
Jun 21, 2022, 3:18:04 AMJun 21
to PAL 6502 computer
Assuming the problem was the setting of the interrupt vectors:

Happened to me too first time. Couldn't figure out why at first (First Book of KIM to the rescue....). 

Then I kept forgetting it regularly, running into the issue repeatedly.

Then I decided to stick a note with the interrupt vectors to my board. That helps. ;)

Cheers,
Hendrik-Jan

Reply all
Reply to author
Forward
0 new messages