troubleshooting the cassette interface

22 views
Skip to first unread message

Will Senn

unread,
Jul 26, 2022, 12:09:07 PM7/26/22
to PAL 6502 computer
All,

I am trying to figure out why I'm not able to load starship off of a cassette tape I recorded it to. I was able to save it to tape without error, but I haven't been able to load it. I don't really know what is going on in there, so for all I know it didn't really successfully save it even though it displayed 0000 XX at the end of 15 minutes or so.

What are some steps I can go through to see what's going on?

I have:
PAL-1 w/all expansions
Califone 3132 Tape recorder w/Index
Rigol Oscillocope, Saelae Logic Analyzer Clone, VOM, etc.

I tested with itsy bitsy programs and it worked fine :).

starship is big and seems appropriate for my first "real" program to save to cassette.

Thanks,

Will

Hans Otten

unread,
Jul 27, 2022, 3:34:07 AM7/27/22
to PAL 6502 computer
This may help:
kimkenner06 (hansotten.nl) this article is in Dutch, on the list of things to translate, so a short extract:

. connect a voltmeter to pin 7 of the LM311 
. start reading the tape
. adjust the pot to a reading of about 2.7V 
This helped me read the tapes I bought with programs like KB-9, MICRO ADE Microchess and tapes I exchanged with other KIM-1 users. 

A scope on this test point would show a nice symmetric pulse. 
 
Of course try with different tape/brand cassette, you may have a bad tape with  dropouts. Avoid the 'hifi' type.
For tapes from other recorders I also adjusted the azimuth of the head (if there is a screw next to the head!) for optimal high pitch sound.

Will Senn

unread,
Jul 27, 2022, 10:22:32 AM7/27/22
to Hans Otten, PAL 6502 computer
Ask and you will receive. Thanks Hans. A lot to go through, but great stuff.

Will
--
You received this message because you are subscribed to a topic in the Google Groups "PAL 6502 computer" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/pal6502/DLJ6QEVBDD0/unsubscribe.
To unsubscribe from this group and all its topics, send an email to pal6502+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/pal6502/72426ad5-211d-4842-b969-19764a1935d9n%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Will Senn

unread,
Jul 27, 2022, 2:41:41 PM7/27/22
to PAL 6502 computer
Here's what I wound up doing and a question:

1. I reran vutape and adjusted VR1 and VR2 per instructions in the manual. Then I hooked up to my Mac and saved  the starship tape audio (just sounds so right) to Audacity. It looked perfect and sounded clean, so it seems like OUT on the expansion is working well. I then played the .wav back over input to the PAL-1 and it worked flawlessly (I set full volume on the MAC side). So, it seems like IN and OUT are working and the cassette card works :).

2. I loaded up PLL SET from FBOK, hooked up PA0 to TIP on IN connector and ran per instructions. Stayed 7 (high), no fluctuation no matter how much I fiddled with VR2. Hooked up logic analyzer and saw oscillation between 165 and 172 us UP then DOWN. So it appears the program (PLL SET) is working on setting PA0, but dunno about read.

3. I tried Han's troubleshooting - reading 1742 for 87, but got C7 instead. I fiddled but got strange results - prolly related to the amplification issue. Will revisit.

4. Did a bunch more experimentation with save and restore with audacity on Mac. After I got it where I wanted it, I added in the cassette recorder. As it turns out, my nifty wifty CALIFONE has a massively amplified OUT (It's used in classrooms). So, I turned the volume WAY down (almost off) until I got a waveform similar to the Mac stuff. I tried saving and restoring the small VUTAPE program and yay, it 'worked'.

Mac recorded and played back stream:
Screen Shot 2022-07-27 at 1.36.04 PM.png

Cassette recorded and played back stream:
Screen Shot 2022-07-27 at 1.38.00 PM.png

I'm not entirely pleased and still have to check it with the longer program, but thought I would share progress.

Will

Will Senn

unread,
Jul 27, 2022, 2:44:05 PM7/27/22
to PAL 6502 computer
oh, and the question... should I be able to run PLL SET as originally written, with the PA0 connected to TIP on the cassette expansion IN connector, or am I doing something wrong. My thought was that PLL SET is just modulating the frequency of the wave output on PA0, so connecting that the TIP on the cassette expansion should work.

Will
Reply all
Reply to author
Forward
0 new messages