P2Pool release 17.0 - Update urgently required

1,096 views
Skip to first unread message

Forrest Voight

unread,
Aug 26, 2017, 4:04:13 PM8/26/17
to p2pool-not...@googlegroups.com
P2Pool release 17.0 - commit hash: 62fa7b020b82a92138d7652c26be2953b26fd4e5

HARDFORK - Upgrade URGENTLY required in the next few days.

Windows binary: http://u.forre.st/u/iqvaqprd/p2pool_win32_17.0.zip
Windows binary signature: http://u.forre.st/u/ysrjpsls/p2pool_win32_17.0.zip.sig
Source zipball: https://github.com/forrestv/p2pool/zipball/17.0
Source tarball: https://github.com/forrestv/p2pool/tarball/17.0

Changes:

* SegWit compatibility
* Increased new transactions size limit per share to allow producing
larger blocks
* Requires Bitcoin >= 0.13.1

SegWit (segregated witness) **has already activated** and for P2Pool
to continue working without producing invalid blocks, everyone needs
to upgrade. At 50% of our hashrate upgrading, P2Pool instances will
start displaying a warning saying that an upgrade is required.
Reaching that point as quickly as possible is very important. And
then, at 95%, users that have not upgraded will be excluded. If
non-upgraded users aren't excluded soon enough, P2Pool users will be
subject to paying other users for invalid work - effectively a
withholding attack.

Due to SegWit already activating upgraded users of P2Pool must not
mine SegWit transactions as they are incompatible with older P2Pool
versions. After v17 shares activate a new release will be made which
removes this restriction.

So, please upgrade to 17.0 now and also tell everyone else to.
Reply all
Reply to author
Forward
0 new messages