Problem installing OVERSIP on Ubuntu 16.04.3 LTS (EC2 instance)

63 views
Skip to first unread message

ravaka

unread,
Sep 21, 2017, 5:23:46 AM9/21/17
to OverSIP
Hello,

i'm trying on install OVERSIP 2.0.x on Ubuntu 16.04.3 LTS

I followed tutorial here : http://oversip.net/documentation/2.0.x/installation/debian_and_ubuntu/

And I get some errors:

...

Building native extensions. This could take a while...
ERROR: Error installing oversip:
ERROR: Failed to build gem native extension.

current directory: /var/lib/gems/2.3.0/gems/eventmachine-le-1.1.7/ext

...

Full log is here : https://gist.github.com/anonymous/ac52a5bde3294952e63525689aefecf0

Is there a workaround ?

Thanks in advance

Iñaki Baz Castillo

unread,
Sep 21, 2017, 5:28:55 AM9/21/17
to ove...@googlegroups.com
The deb packages are currently unmaintained. Try installing oversip from git master branch which uses a modern version of eventmachine rather than the previous eventmachine-le.

BTW, prior to that, try installing the gem eventmachine in the same host to see what happens.

--
You received this message because you are subscribed to the Google Groups "OverSIP" group.
To unsubscribe from this group and stop receiving emails from it, send an email to oversip+unsubscribe@googlegroups.com.
To post to this group, send email to ove...@googlegroups.com.
Visit this group at https://groups.google.com/group/oversip.
For more options, visit https://groups.google.com/d/optout.



--
Iñaki Baz Castillo
<i...@aliax.net>

ravaka

unread,
Sep 21, 2017, 5:37:57 AM9/21/17
to OverSIP
Thank for you answers.

Can you provide some guidelines or steps to install it from git ? Or it the same steps as per documentation ?

Sorry, I am quite a newbie in unix world.

Thanks


Le jeudi 21 septembre 2017 12:28:55 UTC+3, Iñaki Baz Castillo a écrit :
The deb packages are currently unmaintained. Try installing oversip from git master branch which uses a modern version of eventmachine rather than the previous eventmachine-le.

BTW, prior to that, try installing the gem eventmachine in the same host to see what happens.
On Thu, Sep 21, 2017 at 11:23 AM, ravaka <kodd...@gmail.com> wrote:
Hello,

i'm trying on install OVERSIP 2.0.x on Ubuntu 16.04.3 LTS

I followed tutorial here : http://oversip.net/documentation/2.0.x/installation/debian_and_ubuntu/

And I get some errors:

...

Building native extensions. This could take a while...
ERROR: Error installing oversip:
ERROR: Failed to build gem native extension.

current directory: /var/lib/gems/2.3.0/gems/eventmachine-le-1.1.7/ext

...

Full log is here : https://gist.github.com/anonymous/ac52a5bde3294952e63525689aefecf0

Is there a workaround ?

Thanks in advance

--
You received this message because you are subscribed to the Google Groups "OverSIP" group.
To unsubscribe from this group and stop receiving emails from it, send an email to oversip+u...@googlegroups.com.

To post to this group, send email to ove...@googlegroups.com.
Visit this group at https://groups.google.com/group/oversip.
For more options, visit https://groups.google.com/d/optout.
Reply all
Reply to author
Forward
0 new messages