Otvorena mreža preko wifi wan konekcije...

408 views
Skip to first unread message

Valent

unread,
May 13, 2013, 7:40:49 AM5/13/13
to Otvorena Mreza
Bilo je na radionici ali i online pitanja kako spojiti točku otvorene
mreže ali tako da se internet dijeli preko wifi mreže a ne žicom, tj.
ako je vaš wifi router predaleko od lokacije gdje bi postaviti točku
otvorene mreže a komplicirano je između njih dvoje provlačiti lan
kabel.

Evo u ovome ticketu smo raspravili kako se to radi:
http://dev.wlan-si.net/ticket/1066

No ukratko evo što treba napraviti:

1. spojite se preko ssh klijenta na svoj router (linux terminal ili
putty za windowse)
2. instalirajte paket za podršku spajanja na enkriptiran AP:
2.1 # opkg update && opkg install wpad-mini
3. uredite svoj /etc/config/wireless za povezivanje na postojeći AP:
config wifi-iface
option ssid 'name of your AP'
option encryption 'psk2' #encryption of your AP
option device 'radio0' #radio on your node router
option mode 'sta' #sta means client mode
option key 'pass. of your AP'
option network 'wan' #Specifies the networks between
which traffic is relayed

Vedran.Art

unread,
May 13, 2013, 7:49:52 AM5/13/13
to otvoren...@googlegroups.com
Hm, ali onda taj isti router ne mo�e shareati dalje WiFi konekciju?
Odnosno na njega mora biti spojen preko LAN-a drugi router koji �e
shareati konekciju?

Jer npr., frend mi �ivi u neboderu od brijem 14 katova, on je na 5-om i
sada, ako bi htijeli shareati njegovu vezu sa vrha nebodera dalje kako
bih to napravili, morao bih negdje na prozor zrokati jedan router
(spojen preko LAN-a na WAN koji bi bacao signal do gore, pa drugi router
koji bi ga primao, te tre�i router koji bi ga oda�iljao dalje po kvartu?
No, mislim da je to za sada samo san :D Barem taj dio ;) Em zbog
cijene, em zbog psiholo�kih stvari xD

On 13.5.2013. 13:40, Valent wrote:
> Bilo je na radionici ali i online pitanja kako spojiti to�ku otvorene
> mre�e ali tako da se internet dijeli preko wifi mre�e a ne �icom, tj.
> ako je va� wifi router predaleko od lokacije gdje bi postaviti to�ku
> otvorene mre�e a komplicirano je izme�u njih dvoje provla�iti lan
> kabel.
>
> Evo u ovome ticketu smo raspravili kako se to radi:
> http://dev.wlan-si.net/ticket/1066
>
> No ukratko evo �to treba napraviti:
>
> 1. spojite se preko ssh klijenta na svoj router (linux terminal ili
> putty za windowse)
> 2. instalirajte paket za podr�ku spajanja na enkriptiran AP:
> 2.1 # opkg update && opkg install wpad-mini
> 3. uredite svoj /etc/config/wireless za povezivanje na postoje�i AP:

valent....@gmail.com

unread,
May 13, 2013, 8:43:58 AM5/13/13
to otvoren...@googlegroups.com

Može i shera preko wirelessa bez problema. Atheros može imati do 16 "logičkih" wirelessa na jednom fizičkom, onako smo iskoristili tek dva :)

Vedran.Art

unread,
May 13, 2013, 8:44:50 AM5/13/13
to otvoren...@googlegroups.com
Huh, oukej :D

On 13.5.2013. 14:43, valent....@gmail.com wrote:
>
> Mo�e i shera preko wirelessa bez problema. Atheros mo�e imati do 16
> "logi�kih" wirelessa na jednom fizi�kom, onako smo iskoristili tek dva :)
>
> --
> You received this message because you are subscribed to the Google
> Groups "Otvorena Mreza" group.
> To unsubscribe from this group and stop receiving emails from it, send
> an email to otvorena-mrez...@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>
>

Valent

unread,
May 13, 2013, 9:34:20 AM5/13/13
to Otvorena Mreza
> Jer npr., frend mi ivi u neboderu od brijem 14 katova, on je na 5-om i
> sada, ako bi htijeli shareati njegovu vezu sa vrha nebodera dalje kako

Zaboravi penjanje do vrha zgrade za sada ;)
Za početak samo frenda koji je na 5. katu zamoliš da nabavi tp-link
wr741nd i stavi ga na prozor koji gleda prema igralištu i klupama
ispred zgrade.

Tako dok ste vani oko zgrade imate free wifi ;)

Upgrade na ovu prvu verziju je staviti usmjerenu antenu umjesto ove
standardne, npr. postaviš ovu [1] prema dolje i to je to.

[1] http://www.edigital.hr/Dodaci/TP-LINK_TL-ANT2409_antena_9dBi-p36674.html

Valent

unread,
May 13, 2013, 2:39:31 PM5/13/13
to Otvorena Mreza
Izgleda da je openwrt trunk opet skočio s jednom verzijom naprijed...

Probaj pakete instalirati odavdje:
http://bindist.wlan-si.net/profiles/nextgen/ar71xx/

Čak se može podesiti i opkg config datoteku da automatski iz ovog
repozitorija vuće pakete. Javi kako je prošlo.

Valent

unread,
May 13, 2013, 2:56:47 PM5/13/13
to Otvorena Mreza
Jooj, moj zez, s kolegom radim na jednom modu gdje smo čačkali po wpad-
mini paketu, no u pravu si taj nije trebalo instalirati već samo kako
piše ispravno u ticketu wpa-suplicant-mini paket jer on služi za
enkripciju.

dakle: ne "opkg install wpad-mini" već "opkg install wpa-suplicant-
mini" ;)

Kada su mi prsti brži od mozga ;)

Goran Marjanovic

unread,
May 13, 2013, 3:07:15 PM5/13/13
to otvoren...@googlegroups.com
cini se ok,

dakle, da malo raspisemo (za one koji ne znaju da ne traze ;) )

u
~# /etc/opkg.conf
izmjeniti source (prva linija)

# src/gz barrier_breaker http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages
src/gz barrier_breaker http://bindist.wlan-si.net/profiles/nextgen/ar71xx


cini se sve ok onda,..

~# opkg update
Downloading http://bindist.wlan-si.net/profiles/nextgen/ar71xx/Packages.gz.
Updated list of available packages in /var/opkg-lists/barrier_breaker.

Za sada necu nista reinstaliravati jer trenutno sve sljaka ;)
na ovom routeru (tplink 842nd) za sad samo testiram, prebacit cu image stalni node na neki drugi router, pa cu na njemu isprobati,..

dakle uz wpa-suplicant na 842nd sljaka, a ocito je uz njega povukao dependency na wpad-mini.. (ne sjecam se, budem analizirao drugi put,..)

~# opkg list | grep -i wpa
hostapd - 20130302-1 - This package contains a full featured IEEE 802.1x/WPA/EAP/RADIUS Authenticator.
wpa-supplicant - 20130405-1
wpad-mini - 20130302-1 - This package contains a minimal IEEE 802.1x/WPA Authenticator and Supplicant (WPA-PSK only).
wpad-mini - 20130405-1


Darko Busic

unread,
Jul 25, 2013, 9:24:09 AM7/25/13
to otvoren...@googlegroups.com
Jel mogu zamoliti još jednom točne (čitaj: upute za  totalnog glupana) upute za podešavanje Wan-a preko WiFi ?
Pokušao sam sve iz ovoga posta, jedva sam nekako instalirao wpa-suplicant-mini (kako da uopće znam da li je dobro instaliran)
podesio sam /etc/config/wireless i /etc/config/network
ali ruter uopće neće na net, lampica od interneta se više ne pali iako je kabal spojen u WAN.

Uglavnom izgubio sam dobrih 3-4 sata na podešavanje i ruter je blizu toga da ide pod čekić.

U prilogu je wireless config file.

Darko,




Valent Turkovic

unread,
Jul 25, 2013, 12:02:28 PM7/25/13
to otvoren...@googlegroups.com
Darko nije prošao wireless config file na grupu, možda google to filtrira, no samo ih stavi na www.pastebin.com i pošalji link na njih ponovo na grupu kako bi vidjeli što se događa.

Ima li Goran ili netko drugi od ekipa koja je ovo već složila volje napraviti upute i postaviti ih na wiki? Ili makar napisati sve korake.

Trebamo dijeliti znanje međusobno a ovo je savršena prilika za to.

Darko Busic

unread,
Jul 25, 2013, 1:12:31 PM7/25/13
to otvoren...@googlegroups.com
Evo postavio sam još jedan  router, wireless i network files su na: www.imputo.hr/config_files.rar
wpa-supplicant-mini je dobro instaliran,

Napravit ću ja upute samo da mi ovo proradi da vidim šta sam fulao.

LP Darko,


valent....@gmail.com

unread,
Jul 25, 2013, 3:57:37 PM7/25/13
to Otvorena Mreza
Čini mi se kako ti je sve dobro podešeno, pretpostavljam da ti je samo AP stavljen u WPA1 a ne u WPA2 mod.
Probaj u wireless config staviti "psk1" umjesto "psk2" ili "wpa"

Na wikiju su dobro objašnjeni modovi:
http://wiki.openwrt.org/doc/uci/wireless#wpa.modes

A super što ćeš napisati upute, toga nam stvarno fali!

Ekipa iz Slovenije ima pravilo da starija ekipa pomaže SAMO uz uvjet da kada nekome pomogne taj drugi MORA na wiki napisati upute ;) Razmišljam da i mi uvedemo to pravilo ;)

Goran Marjanovic

unread,
Jul 25, 2013, 4:02:33 PM7/25/13
to otvoren...@googlegroups.com
Evo ja sam danas opet "ozivio" svoj node, pa cu ga veceras konfigurirati za wifi,.. pa postavim detalje ako kolega ne uspije prije mene,..

Goran Marjanovic

unread,
Jul 25, 2013, 5:46:04 PM7/25/13
to otvoren...@googlegroups.com
Hej Valent, makli su "wpa-supplicant" (ni mini nema) package iz repository-a

ili su ga makli na drugi link, ja sam prosli puta koristio ovaj:
http://bindist.wlan-si.net/profiles/nextgen/ar71xx

sad ga tu vise nema?!

Goran Marjanovic

unread,
Jul 25, 2013, 6:01:32 PM7/25/13
to otvoren...@googlegroups.com
Zaboravi ;)
Vec je ukljucen u image po defaultu,..

root@xxx:~# opkg list | grep -i wpa

hostapd - 20130405-1 - This package contains a full featured IEEE 802.1x/WPA/EAP/RADIUS Authenticator.
wpad-mini - 20130405-1 - This package contains a minimal IEEE 802.1x/WPA Authenticator and Supplicant (WPA-PSK only).
root@xxx:~# opkg list | grep -i supplicant
wpad-mini - 20130405-1 - This package contains a minimal IEEE 802.1x/WPA Authenticator and Supplicant (WPA-PSK only).


btw. pisem i uputstva usput pa zato nisam prethodno provjerio..

Goran Marjanovic

unread,
Jul 25, 2013, 8:12:37 PM7/25/13
to otvoren...@googlegroups.com

Evo ljudi, u attachmentu je pdf sa slikama, pa neka netko proba slijediti upute, bas sam u detalje isao, osim koristenja "Vi editora" :P

Moj novi node upravo sljaka putem wifi-ja, tako da nema razloga da i vas tako ne radi..

Tko bude htio odraditi wiki, dat cu mu slike i doc pa moze samo kopirati,.. ali eto prvo isprobajte ;)
Otvorena_Over_Wifi_HowTo_For_Dummies.pdf

Darko Busic

unread,
Jul 26, 2013, 5:58:32 AM7/26/13
to otvoren...@googlegroups.com
Upute su odlične, HVALA !!!

Ja sam mojim ruterima promjenio kanal sa 2 na 6 i sad sve radi (nemam pojma da li je do kanala ili  možda što sam oba rutera resetirao)
Malo je glupo što na ruteru ne blinka lampica od interneta  tak da neznaš da li je spojen ili ne dok ne probaš surfati :-(

Kasnije ću pokušati složiti još jedna novi ruter sljedeći upute.

Darko,

Valent

unread,
Jul 26, 2013, 8:08:08 AM7/26/13
to Otvorena Mreza

Odlične su upute ali momci molim vas da sve upute stavite na wiki jer su tamo i sve do sada upute pa kada netko bude trebao sve je na jednome mjestu. Link na wiki šaljem čim sjednem za komp...

--

valent....@gmail.com

unread,
Jul 26, 2013, 8:16:15 AM7/26/13
to Otvorena Mreza

Pregledao sam wiki i trenutno nema howto stranica no zato ćemo ih krenuti i napraviti...

Treba staviti naglasak kako je ovo privremeno samo jer će ovo sve biti integrirano u Nodewatcher 3.0...

Predlažem da nova wiki stranica bude:
http://dev.wlan-si.net/wiki/howto/wanoverwifi

Goran Marjanovic

unread,
Jul 26, 2013, 9:27:46 AM7/26/13
to otvoren...@googlegroups.com
ok, kad uhvatim vremena slozim to tamo, mozda vec i danas,..

eh jos jedna stvar, identificirao sam jedan problem, pa ako netko ima prilike isto probati.
Imam TP-Link WR741ND router, po navedenom spojen, i evo neki android uredjaji se ne mogu spojit na njega, konkretno android 2.3.x, android 4.x rade...
Ovima sto ne rade, jednostavno stoji na "obtaining ip address..."
Pokusat cu analizirati promet na router strani, ali eto, ako netko ima volje i opreme, neka proba,..
Probat cu ga vratiti i u zicni wan mod, premda ne vjerujem da je do toga,..


pozz

valent....@gmail.com

unread,
Jul 26, 2013, 10:12:13 AM7/26/13
to Otvorena Mreza
Trebali bi svi mobiteli raditi, prije godinu i pol dana je bio problem pošto su svi interfacei bili u adhoc modu, no čim se prešlo na klasično AP mod sve je proradilo na svim android telefonima pa stvarno ne kužim što te zeza, jesi li možda vidi da se ne spaja greškom na mesh mrežu koja je adhoc? 

Probaj privremeno zakomentirati mesh interface u wifi configu pa javi da li to pomogne.

Goran Marjanovic

unread,
Jul 26, 2013, 10:26:53 AM7/26/13
to otvoren...@googlegroups.com
Svasta sam probao, doduse, dok sam imao TP-Link 842ND, s njim nije bilo problema, svi su mi se tu u susjedstvu kacili s istim mobitelima bez problema, sad imam 741nd pa kontam da je mozda do njega,..
Ne znam koje su drivere koristili u openwrt i za image za otvorenamreza, no zadnje verzije ddwrt, pa cak i sluzbeni firmware od tp-linka ima problem da se nakon nekog vremena pojavljuje "dissociate" wifi klijenata te se ponasa router kao da je wifi interface down..
a to je ono bas tlaka i velika problematika, resetiranjem routera ili cisto mijenjanjem wifi postavki se stvar rijesi,.. btw. ja sam to rjesavao da sam stavio scheduled cronjob da se restarta svako jutro u 4am, tako da je koliko toliko radio stabilno.

Ovdje se bojim da je slicna shema, ali moram vidjeti da li association od mobitela uopce dolazi do routera i kako mu router responda,.. budem vidio prvo kroz messages,..
Nisam sad pri routeru, ali budem vidio, mozda skuzim do cega je,..
i nije na adhoc, na ap se spaja, probao sam maknuti mesh iface jer oko mene nema nodova na koje bi se eventualno spojio pa nema gubitaka bez tog interface-a,..

thanks, budem vidio pa javim,..

valent....@gmail.com

unread,
Jul 26, 2013, 1:48:36 PM7/26/13
to Otvorena Mreza

Sada nikako nemojte uzimati wr842nd jer je izašao V8 koji nije podržan pod openwrt za sada :(

Goran Marjanovic

unread,
Jul 26, 2013, 4:33:07 PM7/26/13
to otvoren...@googlegroups.com
ne, grijesis ;)
842nd ima samo v1
sigurno mislis na 841nd, on nije podrzan, pa samo da bude jasnije ;)

Darko Busic

unread,
Aug 20, 2013, 11:13:53 AM8/20/13
to otvoren...@googlegroups.com
i opet problemi danas......
znači novi ruter, spojim ga, flash-am ga, sve OK, spojim na svoj WiFi, sve super radi.

Odem kod ljudi i tamo ga ne mogu natjerati ni pod razno se spoji  na net preko WiFi
Pokušavao sam se spojiti na Zyxel P660, to je ona stara kanta od T-Coma.
Probao sam mjenajti encryption WEP, WPA, PSK, PSK1, PSK2 i mjenajti kanale na oba ruter i neće ?????

nažalost sam ga spojio preko kabla i sad je u sredini kuće tak da vani jedva ima signala :-(

šta još mogu probati/raditi ???

Darko

Goran Marjanovic

unread,
Aug 20, 2013, 2:40:55 PM8/20/13
to otvoren...@googlegroups.com
jel mozes uhvatiti screenshot ili uslikati postavke za wifi na tom zyxel routeru (zamagli/izrezi password),
ja kontam da je do enkripcije samo ju treba tocno definirati u onu koja je definirana u tcom routeru (ili eventualno mac filtering ukljucen na zyxelu, no cisto sumnjam u to)

Pa ako mozes neki foto nabacit od wifi postavki na tcom routeru, to bi pomoglo jer bi mogli odrediti tip enkripcije.

I jos jedna stvar mi sad pada na pamet, jer se radi bas o zyxel routeru, oni su malo nazovimo ih "na svoju ruku implementirani"
Znaci, pada mi na pamet (premda je to bilo dosta davno kad sam ga imao u rukama i nastelavao) da ti mozda na tom routeru nije ukljucen NAT u many-to-one modu koji ce dodjeljivati ip adrese.
Taj router je kao sto si rekao relativno star i ima neku njihovu implementaciju dodjeljivanja ip adresa tako da NAT svakako moras ukljuciti (znaci potrazi neki checkbox gdje se navodi NAT = Network Address Translation)
i koliko se sjecam (ne drzi me za rijec, trebao bih bas vidjeti configuration gui routera) treba ga postaviti na SUA protokol, mislim da su 2 ili 3 ponudjena ali jedan od njih je SUA i mora biti ukljucen da bi routeru otvorene-mreze dodijelio ip adresu preko koje ce se moci spojiti na net

I buduci da je to stariji router kontam si da on niti nema podrsku za wpa2 protokol tako da najvecu enkripciju na njemu mozes nastelati na "wpa+psk" (i ne znam jos koji "cypher mode" ponudi, moze biti tkip i aes ) sto i unesi i u konfiguraciju u samom routeru, znaci konfiguracija bi morala biti sljedeca (znaci i metoda enkripcije):
option encryption 'psk+tkip'

moja recimo izgleda na sljedeci nacin (kod mene u routeru u routeru je oznacena kao wpa2 personal):
option encryption 'psk2+tkip+aes'

Znaci sa tim starijim routerima je tlaka, sto jest jest i vjerujem ti da si se napatio no blizu si, samo se treba jos malo poigrati sa samim postavkama kako sam ti napisao (znaci moras ih naci u konfiguraciji routera) i cackati dok ne proradi.

Eto, nadam se da sam makar sa nekim hintovima nabacio na sto bi trebao obratiti pozornost (makar iz vlastitog iskustva koliko se sjecam)

Sretno ;)

Goran Marjanovic

unread,
Aug 27, 2013, 5:36:18 AM8/27/13
to otvoren...@googlegroups.com
Hello,

moze mala pomoc..
Sad imam problem da se konfigurirani router nece spojiti na ISP-ov router,
da li je moguce da mu smeta sto je SSID postavljen sa "razmacima"
eg.
option ssid 'AA BB CC' 

ne vidim drugi razlog, osim sto cu morati i to istestirati, no trenutno nisam u mogucnosti promijeniti ssid dok su mi drugi klijenti spojeni, no budem, ali htio sam cuti misljenje,..

thanks

Valent

unread,
Aug 27, 2013, 10:24:38 AM8/27/13
to otvoren...@googlegroups.com
On Tuesday, 27 August 2013 11:36:18 UTC+2, Goran Marjanovic wrote:
Hello,

moze mala pomoc..
Sad imam problem da se konfigurirani router nece spojiti na ISP-ov router,
da li je moguce da mu smeta sto je SSID postavljen sa "razmacima"
eg.
option ssid 'AA BB CC' 

Definitivno bez razmaka stavi.

Goran Marjanovic

unread,
Aug 27, 2013, 5:31:43 PM8/27/13
to otvoren...@googlegroups.com
Thanks, probat cu, premda na tom routeru ne bih smio mijenjati ssid zbog nekih drugih stvari.. no probat cu na repeateru dic jos neki virtualni iface pa na njega nakaciti ovu otvorenu konekciju...
uvijek neka kemijanja... ;)

Message sent from SGS4

Valent

unread,
Aug 28, 2013, 4:09:45 AM8/28/13
to otvoren...@googlegroups.com
On Tuesday, 27 August 2013 23:31:43 UTC+2, Goran Marjanovic wrote:
Thanks, probat cu, premda na tom routeru ne bih smio mijenjati ssid zbog nekih drugih stvari.. no probat cu na repeateru dic jos neki virtualni iface pa na njega nakaciti ovu otvorenu konekciju...
uvijek neka kemijanja... ;)

ne kužim sada koji ssid ima razmak? AP ili client? Ako na klijentu mijenjaš ssid onda to ne utjeće na druge... molim te pojasni malo detaljnije.

Goran Marjanovic

unread,
Aug 28, 2013, 8:14:53 AM8/28/13
to otvoren...@googlegroups.com
ne, klijent je takav kakav je, dakle klijent je defaultni "otvorenamreza.org"
AP od ISP-a ima podesen SSID sa razmacima, dakle router ssid == otvorenamreza.org se spaja na router preko wifi wan konekcije kojem je ssid definiran sa razmacima, tipa ssid == AA BB CC

nisam jos stigao to isprobati i nastelati, no budem pa javim,..

Valent

unread,
Aug 28, 2013, 9:34:32 AM8/28/13
to otvoren...@googlegroups.com
On Wednesday, 28 August 2013 14:14:53 UTC+2, Goran Marjanovic wrote:
ne, klijent je takav kakav je, dakle klijent je defaultni "otvorenamreza.org"
AP od ISP-a ima podesen SSID sa razmacima, dakle router ssid == otvorenamreza.org se spaja na router preko wifi wan konekcije kojem je ssid definiran sa razmacima, tipa ssid == AA BB CC

nisam jos stigao to isprobati i nastelati, no budem pa javim,..



Koliko znakova ima tvoja šifra bez razmaka? 10 ili 26? Ako je 10 onda je to 40-bitni (često krivo pišu 64-bitni) WEP ključ, a ako je 26 onda je 104-bitni (ne nije 128-bitni ako ćemo biti skroz precizni).
Razmak ti AP vjerovatno samo u sučelju stavi kako bi bilo lakše za pročitati. Probaj otići na EDIT key, pa vidi ima li onda razmak ili ne, ne moraš ga promijeniti, samo provjeri kada odeš na edit ima li razmaka. Mislim da nema, već samo web sučelje to tako napiše za lakše čitanje...

Zato u TPLinku pod key za spajanje obavezno stavi bez razmaka i trebalo bi raditi.

Goran Marjanovic

unread,
Aug 28, 2013, 3:35:06 PM8/28/13
to otvoren...@googlegroups.com
Ssid sadrzi razmake ne password
ssid ima oko 25 charactera a od toga 2 razmaka u imenu, primjer "Moja Mreza Xyz"
Password sadrzi cca 15 charactera, ne sadrzi razmak u kombinaciji charactera.
eh, sad je li do ssid-a moram tek utvrditi, nisam imao vremena se igrati, a lap sam ostavio u firmi pa se ne mogu poigrati na svojoj tocki doma.

drugo sto mi je sumnjivo je moguce da tip enkripcije moram drukcije konfigurirati.
po web configu vidim da je wpa2 personal uz tkip&aes enkripciju pa sam u configu nastelao psk2+tkip+aes
takva identicna konfiguracija kod mene sljaka osim sto je ssid "razumnije" postelan..

tako da se svakako moram poigrati s konfiguracijom da utvrdim priblematiku..

Message sent from SGS4

Goran Marjanovic

unread,
Sep 2, 2013, 3:24:18 PM9/2/13
to otvoren...@googlegroups.com
Napokon sam nasao malo vise vremena da se poigram i istestiram i ovu problematiku na koju sam naletio,..
Dakle, nije problem u razmacima u ssid-u,
problem je bio da package "wpa-supplicant-mini" nije bio instaliran i naravno enkripcija nije funkcionirala.
navedeni paket nisam mogao instalirati jer je bio pogresan repository u "/etc/opkg.conf" naveden te sam ga promjenio u sljedeci:

src/gz attitude_adjustment http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/packages

nakon toga sam instalirao wpa-supplicant-mini:
# opkg install wpa-supplicant-mini

restartao router i sve je sljakalo uz primjerice konfiguraciju u "/etc/config/wireless":

config wifi-iface
    option device 'radio0'             
    option network 'wan'              
    option mode 'sta'                  
    option encryption 'psk2+aes'       # recommended encryption wpa2 (psk2) with aes
    option ssid 'Some Test SSID'      # tested ssid with some spaces in the name
    option key '$SomEthiNg098!'      # recommended passwd used in combination with letters (upper/lower), numbers and spec char's

Dakle, i dalje se sve vrti oko neinstaliranog packagea,..
trebalo bi ga dodati u generator imagea da odmah bude instaliran, uza sve stvarno je tlaka otkriti u cemu bi bio problem,..
evo meni, koji znam sta da trazim i sta da gledam trebalo mi je podosta vremena da skuzim i isprobam kombinacije na koje sam sumnjao a ustvari nisu bile problem.

Naime, cini mi se da sam sa "opkg list | grep wpa" uocio da su potrebni paketi instalirani, no eto previdio sam (zaboravio) na ovaj potrebni.

Dakle, s mog gledista, trebalo bi ga ubaciti da po defaultu bude instaliran i "wpa-supplicant-mini"

Node https://nodes.wlan-si.net/node/e8886bc9-efa1-453d-933f-d889cc74eac5 ce biti "up" sutra tijekom dana, konfiguriran je, samo ga moram ustekati i postaviti na poziciju..

Uglavnom zakljucak je da je config jos uvijek "zaheban" i podlozan greskama pa treba biti pazljiv...


Pozz

Valent Turkovic

unread,
Sep 3, 2013, 4:58:04 AM9/3/13
to Otvorena Mreza
Gorane možeš li dodati preko githuba ovaj paket preko githuba?

bug je već otvoren:
https://dev.wlan-si.net/ticket/1129

preuzimaš ovaj ticket?


2013/9/2 Goran Marjanovic <marjanov...@gmail.com>

--

Goran Marjanovic

unread,
Sep 3, 2013, 7:20:35 AM9/3/13
to otvoren...@googlegroups.com
Ako uhvatim vremena budem,.. malo sam u stisci s vremenom na poslu,.. ali ok, mogu preuzeti na sebe pa kroz par dana budem,..

Valent Turkovic

unread,
Oct 1, 2013, 7:10:23 AM10/1/13
to Otvorena Mreza
Gorane (a može i ostali) možeš li probati da li sada radi dodavanje wpa-supplicant preko firmware generatora.
Ako sada odeš na edit node, tamo dolje pod "optional packages" samo klikneš na "wpa-supplicant-mini" i kada odeš na "generate image" trebao bi dobiti image s već ugrađenim wpa-supplicant paketom.

Ako to radi onda treba i tutorial malo prepraviti, a ako ne onda svakako se javi u ovaj ticket:
https://dev.wlan-si.net/ticket/1129

Darko Busic

unread,
Oct 1, 2013, 9:15:10 AM10/1/13
to otvoren...@googlegroups.com
Ne radi, preko WiFi neće na net.

Znači editirao sam postojeći nod, napucao image ponovo u router.

Morao sam napraviti opkg update + opkg install wpa-supplicant
nakon toga se spojio.

Sada opkg update radi jel su u opkg.conf dodali još jedan source.

Pozzzz Darko,

Goran Marjanovic

unread,
Oct 1, 2013, 5:17:12 PM10/1/13
to otvoren...@googlegroups.com
Malo sam u guzvi ovaj tjedan (a vjerojatno i iduci :P ) pa ne stignem puno,.. vidim da je Darko probao,..

btw. iduci tjedan sam par dana u Zg. pa ako kome sta treba neka javi,..

Valent

unread,
Oct 2, 2013, 9:05:03 AM10/2/13
to otvoren...@googlegroups.com
Napisao sam u ticket da su zaboravili staviti dodavanje paketa ako se označi... eto Kostko je napisao da sada to treba raditi, pa ako imate takvu točku možete provjeriti...

Darko Busic

unread,
Oct 2, 2013, 9:40:00 AM10/2/13
to otvoren...@googlegroups.com
Ne mogu napraviti image :-(


Hello darkoos!
There has been an error in image/config generation for brijesce1/10.254.195.241.

Please try again later or report this if the problem persists.

Thank you for your participation in the project!
Best regards,


On Monday, May 13, 2013 1:40:49 PM UTC+2, Valent wrote:
Bilo je na radionici ali i online pitanja kako spojiti točku otvorene
mreže ali tako da se internet dijeli preko wifi mreže a ne žicom, tj.
ako je vaš wifi router predaleko od lokacije gdje bi postaviti točku
otvorene mreže a komplicirano je između njih dvoje provlačiti lan
kabel.

Evo u ovome ticketu smo raspravili kako se to radi:
http://dev.wlan-si.net/ticket/1066

No ukratko evo što treba napraviti:

1. spojite se preko ssh klijenta na svoj router (linux terminal ili
putty za windowse)
2. instalirajte paket za podršku spajanja na enkriptiran AP:
2.1 # opkg update && opkg install  wpad-mini
3. uredite svoj /etc/config/wireless za povezivanje na postojeći AP:
 config wifi-iface
        option ssid 'name of your AP'
        option encryption 'psk2'      #encryption of your AP
        option device 'radio0'        #radio on your node router
        option mode 'sta'             #sta means client mode
        option key 'pass. of your AP'
        option network 'wan'          #Specifies the networks between
which traffic is relayed

Valent Turkovic

unread,
Oct 2, 2013, 9:49:54 AM10/2/13
to Otvorena Mreza

Bilo bi super ako bi mogao Zoranov router dati ekipi u Protis na reklamaciju...

--

Valent Turkovic

unread,
Oct 2, 2013, 9:52:17 AM10/2/13
to Otvorena Mreza

Uff, ako ti za 5-10 minuta i dalje bude slao ovu grešku skoči na Skype chat pa pitaj ekipu što se događa...

https://dev.wlan-si.net/wiki/GetInvolved/Skype

--

Goran Marjanovic

unread,
Oct 3, 2013, 5:07:23 AM10/3/13
to otvoren...@googlegroups.com
Moze, samo do nedjelje bih ga trebao pokupiti a u srijedu ga mogu ostaviti na reklamaciji,.. to mi je 5min od firme nije bed,..

Goran Marjanovic

unread,
Sep 7, 2016, 4:13:04 PM9/7/16
to Otvorena Mreza
On Monday, May 13, 2013 at 1:40:49 PM UTC+2, Valent wrote:
> Bilo je na radionici ali i online pitanja kako spojiti točku otvorene
> mreže ali tako da se internet dijeli preko wifi mreže a ne žicom, tj.
> ako je vaš wifi router predaleko od lokacije gdje bi postaviti točku
> otvorene mreže a komplicirano je između njih dvoje provlačiti lan
> kabel.
>
> Evo u ovome ticketu smo raspravili kako se to radi:
> http://dev.wlan-si.net/ticket/1066
>
> No ukratko evo što treba napraviti:
>
> 1. spojite se preko ssh klijenta na svoj router (linux terminal ili
> putty za windowse)
> 2. instalirajte paket za podršku spajanja na enkriptiran AP:
> 2.1 # opkg update && opkg install wpad-mini
> 3. uredite svoj /etc/config/wireless za povezivanje na postojeći AP:
> config wifi-iface
> option ssid 'name of your AP'
> option encryption 'psk2' #encryption of your AP
> option device 'radio0' #radio on your node router
> option mode 'sta' #sta means client mode
> option key 'pass. of your AP'
> option network 'wan' #Specifies the networks between
> which traffic is relayed

Je li nesto mijenjano u zadnjim konfiguracijama?
Jucer sam napravio nodeupgrade prvenstveno kako bih povecao qos brzinu na 8/2
Spojen je wan over wifi i radio je do upgradea ok.
Sad nakon upgradea preko lan porta radi ok, medjutim ne digne se wifi interface, ni mesh ni om.org
Jedino sto sam rucno promijenio poslije upgradea je da sam dodao wifi config za sta, i zakomentirao wan u network configu.
Ono, cisto standardna procedura, simple as is.
Ima li nacina da rucno podignem wifi ap interface?
Nesto mi zvoni u glavi da sam tako sta vec radio i da je bio jos neko config, ali evo mi nista ne pada na pamet.. Davno je to bilo..

Tocka je dolje na permalinku, vidi se da je aktivna, ali nazalost samo lan ju moze koristiti, a od toge nema bas koristi :P

https://nodes.wlan-si.net/node/6fb72b30-4178-4038-b538-f4d686dd000d/

Thanks
Reply all
Reply to author
Forward
0 new messages