Veracrypt and OSX Fuse 4.2.1 are not working with Monterey

3,236 views
Skip to first unread message

Sibylle Gatter

unread,
Nov 1, 2021, 1:10:07 PM11/1/21
to macFUSE
Dear Mr Fleischer,

currently, I seem to be having a problem that nobody else has - after some research on my own and after some chats with the Apple support, I found your name on the OSX Fuse site and I hope that you can help me.

I need OSX Fuse for Veracrypt, and everything has always worked perfectly well so far. After upgrading my Mac to OS Monterey, however, I cannot mount my Veracrypt volume any longer. The information I always get is that I should upgrade OSX Fuse to version 2.5 (in fact, I use version 4.2.1).
I have already written an e-mail to idrix.fr to make people aware of the problem, since I am quite desperate to access my documents in the Veracrypt volume again and I would be most grateful for some advice.

Best regards
Sibylle Gatter

brian163

unread,
Nov 3, 2021, 12:11:49 AM11/3/21
to macFUSE
For a point of reference, I had no problem testing the mounting of a Veracrypt (v1.24-v8) volume using FUSE 4.2.1 under macOS 12.0.1 (Monterey) upon seeing your post. (I installed Monterey last week and hadn't even thought to test VeraCrypt but I'm glad you mentioned it. ;-)  )

In my case, I was prompted to re-authorize the FUSE extension during my first attempt to mount, however. It looked like this:

Screen Shot 2021-11-02 at 11.52.18 PM.png

And then this:

Screen Shot 2021-11-02 at 11.52.28 PM.png

So I opened Security Preferences, unlocked the control panel with administrative rights (padlock) and then clicked the Allow button.

Screen Shot 2021-11-02 at 11.52.39 PM.png

It prompted me to restart (as the first notification window suggested), then I re-opened VeraCrypt and mounting works fine.

If you did not go through a similar set of steps, I'd suggest researching FUSE system extension permission related fixes. This does not appear to be a VeraCrypt issue.

Hope that's at least helpful in pointing you in a direction. Best of luck,

Brian

Pinky String

unread,
Nov 7, 2021, 6:55:05 AM11/7/21
to macFUSE
I had exactly this problem.  Forget trying to mess about with different versions of Fuse, check your version of Veracrypt.  Mine was 1.23.  I downloaded version 1.24 and that cured it for me (after a couple of reboots)

Have fun
Pinky

Reply all
Reply to author
Forward
0 new messages