problem with python API

3 views
Skip to first unread message

Mario MINARDI

unread,
Aug 12, 2022, 10:58:52 AM8/12/22
to osti...@googlegroups.com

Hi,

 

I’m writing to you because I’m facing a problem with the OSTINATO python API.

 

I’m currently using the following network architecture:

.

 

I have mininet SDN-enabled switches which make the substrate network and I initialize hosts connected to the switches in the substrate network. I’m using an SDN application to manage the routing, across the substrate network, between end-to-end hosts.

Since I would like to automatize the process of traffic generation, I have included an additional external switch which is connected to all hosts and is in charge of sending the traffic streams to the drone running in each host.

 

Now, if I start the traffic via the GUI in a random hosts, I can see that the traffic is correctly generated (wireshark can  prove that, please see the examples below, traffic generation from host with Ip address 10.0.0.1 to host with IP address 10.0.0.6).

 

 

Then, If I try to initialize the traffic via the python API, I get a strange traffic, please see the picture below.

 

.

 

Is this normal? Or do you have any idea of where may these errors come from?

 

I have also included the pictures as attachments, in case they can’t be viewed from the email directly.

 

Thank you very much in advance.

 

Best regards,

 

Mario Minardi

Doctoral Researcher – SigCom group

SnT – Interdisciplinary Centre for Security, Reliability and Trust

UNIVERSITÉ DU LUXEMBOURG

 

CAMPUS KIRCHBERG
29, avenue John F. Kennedy 
L-1855 Luxembourg Kirchberg
mario....@uni.lu | +352 46 66 44 9464

 

Join the conversation

News | Twitter | Linkedin

 www.securityandtrust.lu

 

architecture.png
packet with GUI.JPG
packet with python API.JPG
Reply all
Reply to author
Forward
0 new messages