Next create a local rule for that command:
<rule id="140125" level="7"> <if_sid>530</if_sid> <match>ossec: output: 'reg QUERY</match> <check_diff /> <description>New USB device connected</description> </rule>Now after a few minutes you will see a directory at /var/ossec/queue/diff/[agent_name]/[rule_id] with the current snapshot of this command
2014/06/04 13:10:11 ossec-agent: Exiting...2014/06/04 13:10:11 ossec-agent: Remote commands are not accepted from the manager. Ignoring it on the agent.conf2014/06/04 13:10:11 ossec-agent(1202): ERROR: Configuration error at 'shared/agent.conf'. Exiting.2014/06/04 13:10:11 ossec-execd(1350): INFO: Active response disabled. Exiting.2014/06/04 13:10:11 ossec-agent(1410): INFO: Reading authentication keys file.2014/06/04 13:10:11 ossec-agent: INFO: Assigning counter for agent AZS1901RG03: '99746:8391'.2014/06/04 13:10:11 ossec-agent: INFO: Assigning sender counter: 7:43712014/06/04 13:10:11 ossec-agent: INFO: Trying to connect to server (10.1.16.26:1514).2014/06/04 13:10:11 ossec-agent: INFO: Using IPv4 for: 10.1.16.26 .2014/06/04 13:10:11 ossec-agent: Starting syscheckd thread.2014/06/04 13:10:11 ossec-rootcheck: INFO: Started (pid: 4924).
2014/06/04 13:53:57 ossec-agent(4102): INFO: Connected to the server (10.1.16.26:1514).2014/06/04 13:53:57 ossec-agent(1951): INFO: Analyzing event log: 'Application'.2014/06/04 13:53:57 ossec-agent(1951): INFO: Analyzing event log: 'Security'.2014/06/04 13:53:57 ossec-agent(1951): INFO: Analyzing event log: 'System'.2014/06/04 13:53:57 ossec-agent: INFO: Monitoring full output of command(360): reg QUERY HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USBSTOR2014/06/04 13:53:57 ossec-agent: INFO: Started (pid: 5832).
syscheck.debug=1
On Jun 4, 2014 5:06 PM, "pmsearle90" <pmsea...@gmail.com> wrote:
>
> Thanks for following up Dan. I apologize for not being clear...
>
> I am not getting the alert log on the server to recognize the insertion or removal.
> I am not getting what Daniel said I should see on the server file structure.
> what could I do to further troubleshoot??
>
> However, FYI>>
> I have just followed your suggestion from another post and changed my set-up. instead of using agent.config , I placed the command in the windows agent ossec.conf file and used the alias' that you suggested:
>>
Commands should go in the ossec.conf, not agent.conf. putting it in the agent.conf requires aditional configuration on the agent.
Dan, could you point me to any upgrade / migration notes or articles...
Thanks,
Paul
You received this message because you are subscribed to a topic in the Google Groups "ossec-list" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/ossec-list/QyRQ-luU7XI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to ossec-list+...@googlegroups.com.