Following only part of a gpx track

60 views
Skip to first unread message

walkab...@gmail.com

unread,
Aug 27, 2021, 12:00:26 PMAug 27
to OsmAnd

Hi guys,

I have gpx track of some bike and hiking trails. Now I want to navigate to a destination and follow parts of one of the trails. In the past I used to select the destination first, then select the gpx trail to follow and deselect the option "follow entire track". The routing would navigate me to the trail, follow the trail until the destination is close and last navigate to the destination. 

I quite liked that functionality.

Hower, for whatever reason this seems not to work any more. When I select a gpx track my destination is replaced by the end of the track. When I replace the destination with my own one again a route is calculated from the end of the track towards my destination. Which is usually not what I want. E.g.if I want to follow a famous trail that is about 100k long only for 10k and have 5k more to my destination. The routing now would route all 100k towards the end of the track, and find a route back to my selected destination. The entire track length is than about 200k instead of around 15k.


Does anyone have an idea about how to get the old behaviour back??

lodrog...@gmail.com

unread,
Aug 27, 2021, 2:42:06 PMAug 27
to OsmAnd
hi,
i don't have any experience with this option into osmand. Also i have not test the 3.9.10 vs 4.0.5 versions for this issue you are saying. But i have an idea.

Try to add a new point as final destination to your "follow track" route. The old one final destination will be now " intermediate stop"
test this and see if this action solve your problem

lodrog...@gmail.com

unread,
Aug 28, 2021, 2:52:22 AMAug 28
to OsmAnd
i just made a test with the procedure i have described above. The results was 100% ok. Now he can solve what the user says into post1

walkab...@gmail.com

unread,
Aug 28, 2021, 3:06:34 AMAug 28
to OsmAnd
I tried this before and now again and it failed for me. The new point is not taken as intermediate destination but the gpx route is followed to the end and next the route to my new destination is calculated.
May be I could edit the track before starting the routing, but that would mean the track is destroyed, so not a good option.
About a year ago the partly track routing worked fine and I used it quite frequently. But with current version from playstore its not working anymore.

Problem is still open .....

lodrog...@gmail.com

unread,
Aug 28, 2021, 3:11:28 AMAug 28
to OsmAnd
if you are doing this
------ I used to select the destination first, then select the gpx trail to follow and deselect the option "follow entire track".
this is not working. Do what i told you into post2

walkab...@gmail.com

unread,
Aug 28, 2021, 3:18:00 AMAug 28
to OsmAnd
Screenshot_20210828-091411_OsmAnd+.jpg
That's what I get, the route goes past my new final destination and comes back from the end of the track.

lodrog...@gmail.com

unread,
Aug 28, 2021, 3:44:46 AMAug 28
to OsmAnd
as i told you, for me, after a test, i had no issue. Maybe my bad english can't help you. I am using google translate
I suggest to contact osmand help desk support

lodrog...@gmail.com

unread,
Aug 28, 2021, 8:23:30 AMAug 28
to OsmAnd
car example
i repeat my test (>40Km). The new results shows issue. When we use "follow the track" with no add new destination, there is no problem.
when i repeat a lot of times, follow the track and add a new destination, 1 up to many times is working. And only the first time. If i exit and run again the app, it works at first time

pedestrian example
i made a new track using "plan route" tool near to my house. I save the track. Then i recall this track and add a new destination point. No issue. I repeat a lot of times this test with every time new point. 100% no issue

conclusion
is there any issue with long distanse route ? maybe
i hope this time to help you

lodrog...@gmail.com

unread,
Aug 28, 2021, 9:41:59 AMAug 28
to OsmAnd
i have send email to osmand help desk for this issue

lodrog...@gmail.com

unread,
Sep 2, 2021, 9:25:31 AMSep 2
to OsmAnd
Reply all
Reply to author
Forward
0 new messages