Stops at 12%

55 views
Skip to first unread message

M Kaiser

unread,
Nov 7, 2015, 6:06:03 PM11/7/15
to Osm2garmin development group
osm2garmin v1.2.271
It loads regional contour files fine, but will not download any planet files. I believe I see why, it is expecting a file called "planet.osm.pbf" but none exists so it displays a 404 error in the output section.
After it processes the regional contours, it just stops and sits there doing nothing, sitting at 12% overall process. CPU usage drops to 1-2% and nothing else happens.

Mike


M Kaiser

unread,
Nov 10, 2015, 6:00:29 PM11/10/15
to Osm2garmin development group
No matter what I do I keep getting the error, the program is trying to download too old of a map file and never continues. Output shows:

Preparing region usa_east directory.
Preparing region usa_west directory.
Found 2 regions to process.
Planet file download started.
usa_east contours update started.
Resuming broken download of planet-150906
Bad response code from server 404 - Not Found.
Download error.


Mike

M Kaiser

unread,
Nov 12, 2015, 11:10:52 AM11/12/15
to Osm2garmin development group
I figured out the problem. I had to delete the planet-150906.osm.pbf, after that I restarted the program and it started right up and downloaded everything.

I did run into another problem where my older Garmin can only use at most 2GB memory card, so I had to reduce the map area to fit to the memory card (resulting in a 1.4GB file). A few hours later it created the new gmapsupp.img, copied that to the memory card directly, and my GPS sees the maps with no problems.

A bit of a pain but it works now, although the only area I have is lower half of the eastern US, which should be fine since I usually don't travel beyond that.



Mike
Reply all
Reply to author
Forward
0 new messages