troubles building subsurface

112 views
Skip to first unread message

guillo...@gmail.com

unread,
Jun 29, 2013, 6:33:26 AM6/29/13
to osm-g...@googlegroups.com
Hello list.

When trying to build subsurface against latest osm-gps-map 1.0, here is the build failure:
+ make
updating version.h to v3.1
    CC main.c
In file included from /usr/include/osmgpsmap-1.0/osm-gps-map-widget.h:46:0,
                 from /usr/include/osmgpsmap-1.0/osm-gps-map-layer.h:43,
                 from /usr/include/osmgpsmap-1.0/osm-gps-map.h:24,
                 from main.c:13:
/usr/include/osmgpsmap-1.0/osm-gps-map-track.h:81:77: error: unknown type name 'GdkRGBA'
make: *** [main.o] Error 1

It used to work correctly with osm-gps-map 0.7, and I'm unable to decide if the issue is in subsurface or in osm-gps-map.
--
Guillaume

John Stowers

unread,
Jun 30, 2013, 4:17:56 PM6/30/13
to osm-gps-map
Hi,

Does subsurface have a gtk3 port?

John



--
Guillaume

--
You received this message because you are subscribed to the Google Groups "osm-gps-map" group.
To unsubscribe from this group and stop receiving emails from it, send an email to osm-gps-map...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
 
 

guillo...@gmail.com

unread,
Jul 3, 2013, 4:08:08 AM7/3/13
to osm-g...@googlegroups.com


Le dimanche 30 juin 2013 22:17:56 UTC+2, John Stowers a écrit :
Hi,

Does subsurface have a gtk3 port?
Apparently not, it seems to be gtk2-only.
--
Guillaume

John Stowers

unread,
Jul 3, 2013, 6:07:05 AM7/3/13
to osm-gps-map
I think they have switched to QT now, because they didn't want to port to gtk3 #ironic


--

Pierre-Yves Chibon

unread,
Jul 3, 2013, 6:19:28 AM7/3/13
to osm-g...@googlegroups.com
On Wed, 2013-07-03 at 12:07 +0200, John Stowers wrote:
> I think they have switched to QT now, because they didn't want to port
> to gtk3 #ironic

They have switched to Qt, but not because of GTK3.

Pierre

John Stowers

unread,
Jul 3, 2013, 7:07:16 AM7/3/13
to osm-gps-map
To answer your original question, the pkg-config files and library paths are different in 1.0 (i.e. this should not happen, the two are parallel installable) unless you modified the subsurface Makefile/configure.ac

John


On Sat, Jun 29, 2013 at 12:33 PM, <guillo...@gmail.com> wrote:

--
Guillaume

--
Reply all
Reply to author
Forward
0 new messages