Unknown payload type when setting mandatory class property from php

Skip to first unread message


Jan 16, 2015, 5:44:47 AM1/16/15
to orient-...@googlegroups.com

I'm getting the error message below on the second ALTER PROPETY .. MANDATORY in the code below. 

It doesn't matter which order they are executed, the first one succeeds and the second one throws an exception. 

When I examine the Course Class in Studio both properties are mandatory.

If I comment the second ALTER PROPETY .. MANDATORY true then no exception is thrown

No errors in the log or the console.

Any ideas?


OrientDB version 1.7.10
"ostico/phporient" : "dev-master" - updated
Windows 7

C:\app\php\latest\php.exe C:\home\Willem\proj\php\myegs\php\db\orient\MandatoryBug.php

Fatal error: Uncaught exception 'PhpOrient\Exceptions\PhpOrientException' with message 'Unknown payload type ' in C:\home\Willem\proj\php\myegs\php\vendor\ostico\phporient\src\PhpOrient\Protocols\Binary\Abstracts\Operation.php on line 573

PhpOrient\Exceptions\PhpOrientException: Unknown payload type in C:\home\Willem\proj\php\myegs\php\vendor\ostico\phporient\src\PhpOrient\Protocols\Binary\Abstracts\Operation.php on line 573

Call Stack:
    0.0010     120608   1. {main}() C:\home\Willem\proj\php\myegs\php\db\orient\MandatoryBug.php:0
    0.4620     405464   2. PhpOrient\PhpOrient->command() C:\home\Willem\proj\php\myegs\php\db\orient\MandatoryBug.php:25
    0.4620     405840   3. PhpOrient\Protocols\Binary\SocketTransport->execute() C:\home\Willem\proj\php\myegs\php\vendor\ostico\phporient\src\PhpOrient\PhpOrient.php:266
    0.4620     406496   4. PhpOrient\Protocols\Binary\Abstracts\Operation->getResponse() C:\home\Willem\proj\php\myegs\php\vendor\ostico\phporient\src\PhpOrient\Protocols\Binary\SocketTransport.php:154
    0.4640     406512   5. PhpOrient\Protocols\Binary\Operations\Command->_read() C:\home\Willem\proj\php\myegs\php\vendor\ostico\phporient\src\PhpOrient\Protocols\Binary\Abstracts\Operation.php:214
    0.4640     406512   6. PhpOrient\Protocols\Binary\Abstracts\Operation->_read_sync() C:\home\Willem\proj\php\myegs\php\vendor\ostico\phporient\src\PhpOrient\Protocols\Binary\Operations\Command.php:191

Process finished with exit code 255

require "../../vendor/autoload.php";
use PhpOrient\PhpOrient;
$cl = new PhpOrient();
'username' => 'root',
'password' => 'root',
'hostname' => 'localhost',
'port' => 2424,

$storageType = PhpOrient::STORAGE_TYPE_PLOCAL;
if ( $cl->dbExists('lms') ){
$cl->dbDrop('lms', $storageType);
$cl->dbCreate('lms', $storageType);
$cl->dbOpen('lms', 'admin', 'admin');
$cl->command('create class Course extends V');
$cl->command('CREATE PROPERTY Course.code String');
$cl->command('CREATE PROPERTY Course.faculty String');
$cl->command('ALTER PROPERTY Course.code MANDATORY true');
$cl->command('ALTER PROPERTY Course.faculty MANDATORY true');


Jan 16, 2015, 6:53:00 PM1/16/15
to orient-...@googlegroups.com
Tried this on 2.0 rc2 with the same result.

It turns out that any command following the alter property command produces this error.

Running the commands directly in studio works fine.
Reply all
Reply to author
0 new messages