Lucene index with PortugueseAnalyzer not returning values

Skip to first unread message


Feb 12, 2015, 10:05:05 AM2/12/15
Hi everyone,

I'm creating a lucene index with the following sql queyr: 

create index Company.description_nif on Company(description,nif) FULLTEXT ENGINE LUCENE METADATA {"analyzer":""}"

When I query the index with the following query I get no results : 

select  from Company  where  description lucene  "Lisboa*" limit 1000

I tried creating the lucene index with the default analyzer and then the select query works fine. I also tried to create the index using other Analyzers, like a French , English, and these work fine as well. also does not return any results, like with the PortugueseAnalyzer. 

I'm guessing this is a problem with the Lucene analyzer, but still, has anyone find this problem with the PortugueseAnalyzer and found a way to get it to work?  Am I forgetting to do anything?

OrientDB logs don't show any errors. 
Running OrientDB 2.0

Reply all
Reply to author
0 new messages