Integration with AWS Amplify having issues

27 views
Skip to first unread message

Trevor Ohlinger

unread,
Jun 21, 2021, 8:00:48 PMJun 21
to ORCID API Users
Hello,

I'm running into issues with my redirects when hosting my Orcid integration inside of AWS Amplify. I'm wondering if anyone else has tried using AWS for their integration and if they might have some idea of what is happening. Here are some pictures of what is happening when hosting from AWS Amplify: 

Here are my redirects:
AWS Amplify Redirects.PNG

Here is what happens when I try to redirect to 

AWS Amplify 502 Error.PNG

If I change the source address to / like all the others here is what I get:

image.png
If anyone has experience with these issues or knows what is going on please let me know. 

Thank you in advance,
Trevor
--

Trevor Ohlinger
Systems Administrator I

Albertsons Library Boise State University


Phone: (208) 426-2311
Email: trevoro...@boisestate.edu
Mail: 1865 W Cesar Chavez Ln, Boise, ID 83725-1030
Location: Library 208-C, Boise, ID 83706
Web: giving.boisestate.edu  |  alumni.boisestate.edu


Make a gift to Albertsons Library today!


Fran Alsina

unread,
Jun 23, 2021, 12:05:59 PMJun 23
to ORCID API Users
Hi Trevor! 

Thanks for all the details provided.

From what we can see in the screenshots, these error messages seem to be happening from the AWS side. ORCID API is not receiving these requests.

However, we've done some research about this and the "502 error" message seems to be an issue regarding the SSL/TLS negotiation. The second "Access denied" error seems to be an issue with the bucket policy on your AWS settings. 

Please, check out these resources that you might find useful here: 

- Regarding the 502 error: 


- Regarding the Access denied / XML error: 


I hope that this information is useful and you're able to fix it. In any case, we'll be waiting for your updates on this.

Thanks!
Fran

Trevor Ohlinger

unread,
Jul 7, 2021, 11:41:25 AMJul 7
to ORCID API Users
I got it working by using documentation related to single-page web apps and changing my redirect URL. Here is a link to the information: https://docs.aws.amazon.com/amplify/latest/userguide/redirects.html

Now I'm having a separate issue where it only updates my database with a user's access tokens and other metadata after they click my link more than once. This is a separate issue, perhaps I should start a new forum post.

Thanks for your help,
Trevor
Reply all
Reply to author
Forward
0 new messages