Oracle enhanced adapter 6.0.0 has been released

13 views
Skip to first unread message

Yasuo Honda

unread,
Aug 17, 2019, 12:17:38 AM8/17/19
to Oracle enhanced adapter for ActiveRecord
Hi,

Oracle enhanced adapter 6.0.0  has been released.
Oracle enhanced adapter 6.0.0.rc2 supports Rails 6.0.0.

Please install and test with your applications by updating your 
Gemfile as follows. 

``` 
gem "activerecord-oracle_enhanced-adapter", "~> 6.0.0" 
``` 

### 6.0.0 / 2019-08-17
Major changes, including changes since 6.0.0.beta1

* Support Rails 6.0.0
* Rails 6 requires Ruby 2.5 [#1801]
* Support longer identifier for Oracle database 12.2 or higher [#1703 #1705]
* Introduce use_shorter_identifier [#1707]
* Change default_sequence_start_value from 10000 to 1 [#1636]
* Address ORA-01795: maximum number of expressions in a list is 1000

CI
* CI against JRuby 9.2.8.0 #1912

For all changes and fixes please read the following document.

Thanks,
Reply all
Reply to author
Forward
0 new messages