An error when i download ruote

34 views
Skip to first unread message

范佳兴

unread,
Nov 17, 2013, 9:41:30 AM11/17/13
to openwfe...@googlegroups.com
steven@ubuntu:~/ruote$ gem -v
2.1.11
steven@ubuntu:~/ruote$ ruby -v
ruby 2.0.0p247 (2013-06-27 revision 41674) [i686-linux]
steven@ubuntu:~/ruote$ bundle -v
Bundler version 1.3.5
steven@ubuntu:~/ruote$ 


the gems i installed:

steven@ubuntu:~/ruote$ gem list

*** LOCAL GEMS ***

actionmailer (4.0.0)
actionpack (4.0.0)
activemodel (4.0.0)
activerecord (4.0.0)
activerecord-deprecated_finders (1.0.3)
activesupport (4.0.0)
arel (4.0.1, 4.0.0)
arrayfields (4.9.0)
atomic (1.1.14)
awesome_print (1.2.0)
builder (3.1.4)
bundler (1.3.5)
bundler-unload (1.0.2)
cane (2.6.1)
chronic (0.10.2)
churn (0.0.34)
code_analyzer (0.4.3)
code_metrics (0.1.2)
coderay (1.1.0)
coffee-rails (4.0.1, 4.0.0)
coffee-script (2.2.0)
coffee-script-source (1.6.3)
colored (1.2)
daemon (1.1.0)
daemons (1.1.9)
erubis (2.7.0)
execjs (2.0.2)
executable-hooks (1.2.3)
fattr (2.2.1)
file-tail (1.0.12)
flay (2.4.0)
flog (4.2.0)
hike (1.2.3)
hirb (0.7.1)
i18n (0.6.5)
jbuilder (1.5.2, 1.5.1)
jquery-rails (3.0.4)
json (1.8.1, 1.8.0)
json_pure (1.8.1)
mail (2.5.4)
main (5.2.0)
map (6.5.1)
metric_fu (4.5.2)
metric_fu-Saikuro (1.1.1.0)
mime-types (1.25)
minitest (4.7.5)
multi_json (1.8.2, 1.8.1)
mysql (2.9.1)
mysql2 (0.3.13)
parallel (0.9.0)
polyglot (0.3.3)
rack (1.5.2)
rack-test (0.6.2)
rails (4.0.0)
rails_best_practices (1.14.4)
railties (4.0.0)
rake (10.1.0)
rdoc (3.12.2)
redcard (1.1.0)
reek (1.3.4)
require_all (1.3.2)
roodi (3.3.1)
ruby-progressbar (1.2.0)
rubygems-bundler (1.3.4)
rubygems-update (2.1.11)
rufus-scheduler (3.0.2)
rvm (1.11.3.8)
sass (3.2.12)
sass-rails (4.0.1, 4.0.0)
sdoc (0.3.20)
sprockets (2.10.0)
sprockets-rails (2.0.1, 2.0.0)
sqlite3 (1.3.8)
thor (0.18.1)
thread_safe (0.1.3)
tilt (1.4.1)
tins (0.13.1)
treetop (1.4.15)
turbolinks (1.3.0)
tzinfo (0.3.38, 0.3.37)
uglifier (2.3.1, 2.3.0, 2.2.1)


steven@ubuntu:~/ruote$ gem install ruote
ERROR:  While executing gem ... (Gem::ImpossibleDependenciesError)
    ruby_parser-2.3.1 requires sexp_processor (~> 3.0) but it conflicted:
  Activated sexp_processor-3.2.0 instead of (~> 4.0) via:
    ruby2ruby-2.0.6, sourcify-0.5.0, ruote-2.3.0.2


John Mettraux

unread,
Nov 17, 2013, 4:04:55 PM11/17/13
to openwfe...@googlegroups.com

On Sun, Nov 17, 2013 at 06:41:30AM -0800, 范佳兴 wrote:
>
> steven@ubuntu:~/ruote$ gem install ruote
> ERROR: While executing gem ... (Gem::ImpossibleDependenciesError)
> ruby_parser-2.3.1 requires sexp_processor (~> 3.0) but it conflicted:
> Activated sexp_processor-3.2.0 instead of (~> 4.0) via:
> ruby2ruby-2.0.6, sourcify-0.5.0, ruote-2.3.0.2

Hello Steven,

welcome to the ruote mailing list.

This Gemfile should help you:

https://gist.github.com/jmettraux/22f24fca70c5a116b01c

Please note that active development on ruote has stopped. The project is
maintained but does not continue. See
https://groups.google.com/forum/#!topic/openwferu-users/g0jZuWeoXOA


Best regards,

--
John Mettraux - http://lambda.io/jmettraux

Reply all
Reply to author
Forward
0 new messages