See the comment in the OpenSocial specification on the Views. We can
http://codereview.appspot.com/144071/diff/1/2
File draft/Gadgets-API-Specification.xml (left):
http://codereview.appspot.com/144071/diff/1/2#oldcode574
Line 574: <t>sign_owner: gadgets.io.RequestParameters.SIGN_OWNER
(default 'true')</t>
keep these here the same way.
agreed
http://codereview.appspot.com/144071/diff/1/2#oldcode841
Line 841: <t hangText="opensocial_app_url">Required. The URL of the
applicationagreed. See notes in the OpenSocial specification on views.
http://codereview.appspot.com/144071/diff/1/2#oldcode845
Line 845: <t hangText="opensocial_instance_id">Optional. An opaque
identifier
I think we keep this whole section. We grandfather in the names (e.g.
keep "opensocial" prefix). owner_id is optional for gadgets, but in the
OS spec described as required.
For gadgets - we can describe the owner is the user who went through the
process of subscribing to the gadget or placing the gadget on their
page. The viewer would be the current logged in user or the reserved
word "guest" for someone not logged in.
For OS we would keep the more precise wordings.
BTW - We have gadgets where the owner is either irrelevant or implicit,
and at times the viewer is more important.
OK
http://codereview.appspot.com/144071/diff/1/2
File draft/Gadgets-API-Specification.xml (right):
http://codereview.appspot.com/144071/diff/1/2#newcode71
Line 71: capabilities like a rich set of social APIs.</t>See my notes on the OpenSocial spec, in a similar section.
http://codereview.appspot.com/144071/diff/1/2#newcode864
Line 864:
https://[container-hostname]/[application-name]/certificates/xoauth_public_keyvalueI like the absence of <application>, just worried changing it might look
http://codereview.appspot.com/144071/diff/1/3
File draft/OpenSocial-Specification.xml (right):
http://codereview.appspot.com/144071/diff/1/3#newcode512
Line 512: <section title="Public Key Location">
like "breaking" backwards compatibility. Of course the value is only
"recommended".
It could be worded like, "The recommended name is <the one w/o
application>. Some containers may wish to support <the one with
application> as well for compatibility with versions of the
specification prior to 1.0.
I can put them back along with the words:
http://codereview.appspot.com/144071/diff/1/3#newcode517
Line 517: <section title="gadgets.views.ViewType"
"The following are some values that may be supported by the application.
Should the application support them, they must be implemented as
follows."
This will provide some common language between different applications.