LUA version

6 views
Skip to first unread message

Saint Michael

unread,
Apr 29, 2021, 3:10:23 PMApr 29
to openre...@googlegroups.com
I installed Openresty and it works fine. 
But if I type "lua" at the command line, a really old version of LUA shows up, 5.1.5, from 2006. 
What version of lua does openresty use?
can I upgrade LUA?
I want to program  in LUA outside Openresty and use the same version of the language.


Aapo Talvensaari

unread,
Apr 29, 2021, 3:40:58 PMApr 29
to openre...@googlegroups.com
OpenResty uses LuaJIT so you are stuck with 5.1 + most of 5.2. And that’s about it. Also you need to use OpenResty network primitives for all your network code, otherwise you will block the workers.

--
You received this message because you are subscribed to the Google Groups "openresty-en" group.
To unsubscribe from this group and stop receiving emails from it, send an email to openresty-en...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/openresty-en/CAC9cSOAk6-p2LAS2zmz9T%3Dkd4v92WtdqDUWw-Bvv-R%2B4o7%2BUMA%40mail.gmail.com.
Reply all
Reply to author
Forward
0 new messages