I was going to take a crack getting rid of some of the many Throwable.printStackTrace() calls that we have scattered about, converting them to use SLF4J logging, but in the process noticed that we've got a diversity of naming schemes for the loggers which include (complete list in the attachment):
1. lowercase snake_case based loosely on class name or functional area e.g. "refine_server"
2. as above with spaces e.g. "open office" for OdsImporter
3. as above with hyphens e.g. "refine-client"
4. a mix of separators e.g. "importing-controller_command"
5. Java class name in CamelCase using both string ("JsonParser") and static class (JsonImporter.class) as well as instance variable (getClass())
I don't think it's a high priority to fix the existing usage, but it would be useful to have a standard naming scheme going forward.
I propose that static loggers be declared using:
static final private Logger logger = LoggerFactory.getLogger(MyClassName.class);
and that instance loggers using:
final protected Logger logger = LoggerFactory.getLogger(getClass());