OQ engine Development

26 views
Skip to first unread message

Carlos Parraguez Cabrera

unread,
Dec 8, 2020, 5:47:55 PM12/8/20
to OpenQuake Users

Hi I was installing the OQ developer but I have a problem executing the command

# For Linux
pip install -r oq-engine/requirements-py36-linux64.txt -r oq-engine/requirements-extra-py36-linux64.txt

Appearing the following error:



 someone knows how to fix it i am new to linux.

Antonio Ettorre

unread,
Dec 10, 2020, 6:03:26 AM12/10/20
to OpenQuake Users
Hi Carlos, 
 We change the numpy versions and now the requirements are correct.
We have also a new installer that work with the system Python.
 Instructions:

please let us know if it works for you.

Antonio

Michele Simionato

unread,
Dec 10, 2020, 6:12:31 AM12/10/20
to OpenQuake Users
On Thursday, December 10, 2020 at 12:03:26 PM UTC+1 Antonio Ettorre wrote:
Hi Carlos, 
 We change the numpy versions and now the requirements are correct.
We have also a new installer that work with the system Python.
 Instructions:


These instructions are incorrect, you need to clone the repository if you want to install in devel mode, so please disregard the first line.

     Michele 

Carlos Parraguez Cabrera

unread,
Dec 10, 2020, 2:45:59 PM12/10/20
to OpenQuake Users

Thank you both for your response. 
Michele's answer was the one that worked for me, although I still can't understand why that line didn't work for me yesterday hahaha.

Antonio Ettorre

unread,
Dec 10, 2020, 2:50:25 PM12/10/20
to openqua...@googlegroups.com
Because we change the release for numpy wheel and don't update correctly the requirements files for python 3.6.
In this case Antonio did that mistake...

Antonio

--
You received this message because you are subscribed to a topic in the Google Groups "OpenQuake Users" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/openquake-users/75PLqpo6qgk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to openquake-use...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/openquake-users/2641994d-43f8-42f4-a58e-70d77444e2cfn%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages