OpenQuake

53 views
Skip to first unread message

zkarim...@gmail.com

unread,
Dec 3, 2020, 3:18:40 AM12/3/20
to OpenQuake Users
Hi all,

I'm trying to run RMTK but unfortunately have encountered some errors.
I ran the VM VirtualBox 6.1 for windows and then installed ubuntu 20.
Then according to the user manual of RMTK, I downloaded related codes as a zipped package from :

According to the RMTK user manual, "OpenSees for ubuntu is part of the RMTK distribution" and it’s located in :
/home/rmtk-master/bin/OpenSees.u1604
and it should be loaded automatically by RMTK scripts. But when I tried to run it, I have encountered an error as follows:
"Error! /home/rmtk-master/bin/OpenSees.u1604 is not UTF encoded saving disabled"

Please let me know what is the problem and how to fix it?
Which version of ubuntu would you recommend me to install so that I can use all the RMTK modules?
According to the user manual, knowledge of python programming language is not necessary. Please tell me which version of python I need to install ??

Many thanks,
Zarrin

peter...@gmail.com

unread,
Dec 12, 2020, 1:19:30 AM12/12/20
to OpenQuake Users
Hi,

could you please be more specific what command generates the error - is it some of the notebooks in
/rmtk-master/notebooks/vulnerability/derivation_fragility/NLTHA_on_SDOF

that OpenSees seems to be built for ubuntu 16.04 and you are using it in 20.04 but should not be a problem (unless you have some binary libraries on the system...)
On some stackoverflow site they say "is not UTF encoded saving disabled" actually means: I HAVE NO IDEA HOW TO DISPLAY THIS DATA ! - Yours Jupyter
And in fact there is no error...

Thank you
Peter

Dátum: štvrtok 3. decembra 2020, čas: 9:18:40 UTC+1, odosielateľ: zkarim...@gmail.com

peter...@gmail.com

unread,
Dec 12, 2020, 11:20:10 PM12/12/20
to OpenQuake Users
Hmm, when I an trying to run OpenSees.u1604 under ubuntu 20.04, it complains about libfortran.so.3 and I read that this is no longer supported for ubuntu 20.04... so probably best to try on ubuntu 16.04 ...

Peter

Dátum: sobota 12. decembra 2020, čas: 7:19:30 UTC+1, odosielateľ: peter...@gmail.com
Reply all
Reply to author
Forward
0 new messages