Invalid File Specification error

Skip to first unread message

Jordan D'Addeo

Feb 27, 2023, 1:59:27 PM2/27/23
to openpyxl-users
I've been using openpyxl to open and process .xlsx files output by some scientific equipment. Apparently, our machine recently got a software update that seems to have changed the file formatting in some non-obvious way - although I can open the file using Excel or Numbers, I get an error, "UserWarning: File contains an invalid specification for 0. This will be removed" and no data can be extracted from the file with openpyxl. Simply opening the document in Excel and re-exporting it fixes the issue, so it doesn't seem to be related to the data in the files, but something specifically about how the files are being created by our machine. Based on Stack Overflow posts with the same error message, it seems like something related to Strict Open XML format? I'm not exactly sure what's gong on. 

I was using openpyxl 3.0.10, but tried upgrading to 3.1.1 and the issue was still present. I'm on a Mac and using the load_workbook method with the  flags read_only=True, data_only=True. 

I can't change how our equipment operates, and I can't manually re-export every single file. Could this be a case of user error? If so, what can I try? Do I have to use another library instead? If so, does anyone here have one they'd recommend? 

Jordan D'Addeo
Reply all
Reply to author
0 new messages