Parts are being rotated 90 degrees.

48 views
Skip to first unread message

Mark R

unread,
Nov 27, 2021, 7:16:10 AM11/27/21
to OpenPnP
As the subject says.

Every single part gets rotated by 90 degrees anticlockwise.
I ended up this way by updating to the latest version. 2021-11-07?
The previous version that I was using was from earlier this year - January or so.
Everything worked fine prior to the update. Shame on me... I didn't back anything up so im literally stuck with what I have.

I literally don't know what to check. I have probably caused more harm than good by fiddling with it. Looking for guidance. What do I check to see why it's decided to rotate everything anticlockwise by 90 degrees?

Machine specifics:
Liteplacer with a tinyg. Nothing exotic.

Ideas? I am fresh out. I've been at it for about 8 hours now :(

mark maker

unread,
Nov 27, 2021, 8:54:37 AM11/27/21
to ope...@googlegroups.com

Hi Mark R

Some questions:

  1. Testing version or normal version?
  2. What kind of feeder?
  3. With or without bottom vision alignment? Pre-rotate or not?
  4. Have you played around with the new Rotation Mode?

You might wan to send your machine.xml and log at TRACE level. Best send the full log of a session where you place one part.

https://github.com/openpnp/openpnp/wiki/FAQ#where-are-configuration-and-log-files-located

> Shame on me... I didn't back anything up so im literally stuck with what I have.

OpenPnP has backed up your old machine.xml in the backups/ sub-folder. Unless you have changed computer, it is likely still there. Any old version of OpenPnP can also be downloaded.

But first let's try and fix the problem!

_Mark

--
You received this message because you are subscribed to the Google Groups "OpenPnP" group.
To unsubscribe from this group and stop receiving emails from it, send an email to openpnp+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/openpnp/beafd0f2-f22f-4a69-8975-0d996071e11cn%40googlegroups.com.

Mark Rutherford

unread,
Nov 29, 2021, 7:05:51 AM11/29/21
to ope...@googlegroups.com
First, let me apologise for the late response.
I had something come up yesterday and I wanted to take a fresh look to make sure I covered everything.

Here is what I found out...
After I deleted all of the feeders and ran through the camera calibrations one last time it seems to have sorted itself.
Not sure which one did it, but whatever was misconfigured got set correctly.
Might have been a senior moment.. or PEBKAC :)

The new secondary homing fiducial is something new. I might have questions about that but that's for a new thread.
Thanks for offering to help.



You received this message because you are subscribed to a topic in the Google Groups "OpenPnP" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/openpnp/uiPsTEM-eek/unsubscribe.
To unsubscribe from this group and all its topics, send an email to openpnp+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/openpnp/206fcba2-4a63-8b8a-f62b-27bb95cb9061%40makr.zone.

mark maker

unread,
Nov 29, 2021, 1:30:34 PM11/29/21
to ope...@googlegroups.com

Glad it is resolved.

> The new secondary homing fiducial is something new.

Just for clarification: Its not a homing fiducial. The primary and secondary calibration fiducial are usually separate from the homing fiducial. I recommend creating a removable calibration rig, on a spare PCB. Mount it where you would a PCB:

Watch the video, read the Wiki linked here:

https://makr.zone/openpnp-automatic-machine-calibration-with-issues-solutions/676/

_Mark

Reply all
Reply to author
Forward
0 new messages