Kinect on Debian - The device is not connected!

1824 views
Skip to first unread message

makiavel

unread,
Oct 23, 2011, 1:29:10 PM10/23/11
to OpenNI
Hi there!

I installed both the OpenNI (stable) and PrimeSense Sensor Module for
OpenNI (stable). I've followed both README files.
But when I run the samples on my Debian squeeze I got this error
message!

./Sample-NiSimpleRead
Reading config from: '../../../../Data/SamplesConfig.xml'
One or more of the following nodes could not be enumerated:

Device: PrimeSense/SensorV2/5.0.4.3: The device is not connected!

This device is connected, but the green led is blinking! What am I
missing?...

Regards!

makiavel

unread,
Oct 23, 2011, 5:43:38 PM10/23/11
to OpenNI
Tested on ubuntu 11.10 and still can get the device connected!! :o

Hendra

unread,
Oct 23, 2011, 5:46:07 PM10/23/11
to openn...@googlegroups.com
the green LED is supposed to blink, try to run lsusb, see if the kinect is properly listed

--
You received this message because you are subscribed to the Google Groups "OpenNI" group.
To post to this group, send email to openn...@googlegroups.com.
To unsubscribe from this group, send email to openni-dev+...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/openni-dev?hl=en.




--
Best Regards, and Thank you,
Hendra

makiavel

unread,
Oct 23, 2011, 9:06:57 PM10/23/11
to OpenNI
I get this error when I ./RedistMaker ! (unstable version + debian
squeeze)

../../../../Source/XnCore/XnBuffer.h:152: error: expected declaration
before ‘}’ token
make[1]: *** [Release/XnBuffer.o] Error 1
make[1]: Leaving directory `/home/paulo/OpenNI/Platform/Linux-x86/
Redist/Sensor/Platform/Linux-x86/Build/XnCore'
make: *** [XnCore] Error 2

lsusb:
(...)
Bus 001 Device 008: ID 045e:02ae Microsoft Corp. Xbox NUI Camera
Bus 001 Device 007: ID 045e:02ad Microsoft Corp. Xbox NUI Audio
Bus 001 Device 006: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor
(...)

Seems all right!

On 23 Out, 22:46, Hendra <hendra2...@gmail.com> wrote:
> the green LED is supposed to blink, try to run lsusb, see if the kinect is
> properly listed
>

Lance Drake

unread,
Oct 24, 2011, 3:17:16 PM10/24/11
to OpenNI
Hi OpenNI/PrimeSense people,

The lack of instrumentation (as well as sufficient error reporting) is
a real problem with this software.

At this point, with the new materials recently posted, I am "dead in
the water" because an error is being encountered and there is
absolutely no indication as to what is the complaint.

Everything was FINE until the 'install.sh' scripts were run for the
three libraries (OpenNI /SensorKinect / NITE - in that order)

The error occurs during the call to
"g_Context.InitFromXmlFile(SAMPLE_XML_PATH, g_ScriptNode, &errors);"
I have managed to determine that the thread of execution gets into
"xnScriptNodeRun" which then calls "DoesPropertyExist" whereupon a bus
error occurs due to (what appears to be) a NULL reference to
'something' - where everything stops and, as TV-cop Barreta used to
say, "Dat's deh name uh DAT tune".

I would like to suggest that the code which kicks off execution be
provided with better error protection and better error reporting.

Also - can anyone suggest what it is that is missing in this picture?
Why is "DoesPropertyExist" failing?

(PS: target = MacOSX)

Thanks!

makiavel

unread,
Oct 24, 2011, 4:08:30 PM10/24/11
to OpenNI
Finally I got everything working both and windows and linux! It was
really dificult! I think you should provide better and updated
documentation!!!

Here is the guide I followed. I updated it a little bit. Hope it helps
someone! I got it working perfectly on my Debian.

They recommend Ubuntu 10.10 or greater. I had done it on Debian 6

STEP 1
------
Download the OpenNI modules appropriate for your operating system from
http://75.98.78.94/Downloads/OpenNIModules.aspx

NOTE: I tried the unstable versions and it worked fine.

You should download these three:
OpenNI binaries
OpenNI compliant middleware binaries
OpenNI compliant hardware binaries

The downloaded files should like these:
->OpenNI-Bin-Linux32-v1.1.0.41.tar.bz2
->Nite-1.3.1.5.tar.bz2
->Sensor-Bin-Linux32-v5.0.1.32.tar.bz2

Make a new folder called kinect
$ cd
$ mkdir kinect
$ cd kinect
and extract the downloaded files into it.

STEP 2
------
Update your linux
$ sudo apt-get update
install these files which are necessary for proper installation of
drivers
$ sudo apt-get install mono-complete
$ sudo apt-get install libusb-1.0-0-dev
$ sudo apt-get install freeglut3-dev

STEP 3
------
The extracted folders in step 1 will be
->OpenNI-Bin-Linux32-v1.1.0.41
->Sensor-Bin-Linux32-v5.0.1.32
->Nite-1.3.1.5
rename it to OpenNI, Sensor, Nite respectively
Download the folder SensorKinect from https://github.com/avin2/SensorKinect
Extract the folder to kinect folder and rename it to SensorKinect

STEP 4
------
Go to the folder OpenNI, Sensor, Nite and run sudo ./install.sh
$ cd
$ cd kinect
$ cd OpenNI
$ sudo ./install.sh
Check if everything went OK!
$ cd ../Sensor
$ sudo ./install.sh
Check if everything went OK!
$ cd ../Nite
$ sudo ./install.sh
Check if everything went OK!
Use this license when asked during the installation:
0KOIk2JeIBYClPWVnMoRKn5cdY4=
$ cd ../SensorKinect/Platform/Linux-x86/CreateRedist/
$ sudo ./RedistMaker
$ cd ../Redist
$ sudo ./install.sh
Check if everything went OK!
You should be done by now. In case of any confusion refer the README
in SensorKinect folder.

STEP 5
------
Test if everything is working fine
Connect you kinect and run the samples from the OpenNI folder
$ cd ~/kinect/OpenNI/Samples/Bin/Release/
(assuming the kinect folder is in home folder, otherwise go to the
respective folder)
$ ./NiViewer
You should get the depth map and image stream on your window.
--DONE--

Giovanni Saponaro

unread,
Oct 24, 2011, 4:42:29 PM10/24/11
to openn...@googlegroups.com
On 24 October 2011 21:08, makiavel <paulojor...@gmail.com> wrote:
> Finally I got everything working both and windows and linux! It was
> really dificult! I think you should provide better and updated
> documentation!!!
> [...]

Dear makiavel,

just a minor note about your guide. As far as I know, you do not need
to install OpenNI's Sensor *and* SensorKinect, as that is redundant
(although it doesn't break things per se).

OpenNI.org's version of the Sensor package is used for hardware
different than the Kinect, such as PrimeSense SDK and Asus Xtion PRO.
On the other hand, avin2's patched version of Sensor, called
SensorKinect, works with the Kinect. Therefore, in your case, you only
need SensorKinect.

Also, I agree with you about the state of the documentation: it
certainly has room for improvement.

Ciao,
-Giovanni

makiavel

unread,
Oct 25, 2011, 8:13:44 AM10/25/11
to OpenNI
Obrigado Giovanni! Now I understand why I couldn't get my kinect to
work without SensorKinect!
I usually only installed OpenNI, Sensor and NITE... Then I gave
SensorKinect a try and voilá!

Paulo

On 24 Out, 21:42, Giovanni Saponaro <giovanni.sapon...@gmail.com>
wrote:

Alessandro Diogo Brückheimer

unread,
Oct 25, 2011, 9:58:41 PM10/25/11
to openn...@googlegroups.com
We really need to do something to make things simpler.

Alessandro Diogo Brückheimer
alebruck at gmail dot com



エルマン 「Herman」

unread,
Oct 30, 2011, 9:57:47 PM10/30/11
to openn...@googlegroups.com
Hi there, I have tested this way to install OpenNI / NITE on ubuntu 32 bits and always shows segmentation fault when executing the samples

2011/10/25 Alessandro Diogo Brückheimer <aleb...@gmail.com>

エルマン 「Herman」

unread,
Oct 30, 2011, 10:08:54 PM10/30/11
to openn...@googlegroups.com
Hi there, it works now

when building sensorkinect (avin2), go to SensorKinect/Plattform/Linux-x86/Build

sudo make clean
sudo make 
sudo make install


instead of CreateRedist/ ./RedistMaker

and it worked well for me.

thanks

2011/10/30 エルマン 「Herman」 <hben...@gmail.com>

maiatoday

unread,
Nov 1, 2011, 2:25:06 AM11/1/11
to OpenNI
I recently upgraded to ubuntu 11.10 and my kinect stopped working even
though everything was fine before. I forget what the exact error
message was something to the effect that it could not So a heads up.

To solve the problem temporarily I did typed:
sudo rmmod gspca_kinect

It seems there is a module that grabs the kinect and won't let OpenNI
use it.

If this works for you you can blacklist the loading of this module
open /etc/modprobe.d/blacklist file and add gspca_kinect using
following syntax:
blacklist gspca_kinect

this will stop it from loading even if you reboot. If you need it
again you can remove the blacklist.

before doing this maybe try an lsmod to see if the module is in fact
loaded.

Reply all
Reply to author
Forward
0 new messages