High Speed fan issue edgecore as7512-32x

49 views
Skip to first unread message

Rizki Ariyanto

unread,
Aug 28, 2020, 4:30:40 AM8/28/20
to opennetworklinux
Hi All,

I have as7512-32x ONL installed, after successfully install, the fan seems can't auto controlling, its always high speed, is there any example how to auto controll fan like normal pc / server ?

here is output from "sensors" command :

as7512_32x_fan-i2c-2-66
Adapter: i2c-0-mux (chan_id 0)
fan1:             N/A
fan2:             N/A
fan3:             N/A
fan4:             N/A
fan5:             N/A
fan6:             N/A


here is "onlpd" command output for the fan :

fan @ 1 = {
       Description: Chassis Fan 1
       Status: 0x00000009 [ PRESENT,F2B ]
       Caps:   0x00000038 [ SET_PERCENTAGE,GET_RPM,GET_PERCENTAGE ]
       RPM:    17800
       Per:    98
       Model:  NULL
       SN:     NULL
   }
   fan @ 2 = {
       Description: Chassis Fan 2
       Status: 0x00000009 [ PRESENT,F2B ]
       Caps:   0x00000038 [ SET_PERCENTAGE,GET_RPM,GET_PERCENTAGE ]
       RPM:    17900
       Per:    99
       Model:  NULL
       SN:     NULL
   }
   fan @ 3 = {
       Description: Chassis Fan 3
       Status: 0x00000009 [ PRESENT,F2B ]
       Caps:   0x00000038 [ SET_PERCENTAGE,GET_RPM,GET_PERCENTAGE ]
       RPM:    17700
       Per:    98
       Model:  NULL
       SN:     NULL
   }
   fan @ 4 = {
       Description: Chassis Fan 4
       Status: 0x00000009 [ PRESENT,F2B ]
       Caps:   0x00000038 [ SET_PERCENTAGE,GET_RPM,GET_PERCENTAGE ]
       RPM:    17800
       Per:    98
       Model:  NULL
       SN:     NULL
   }
   fan @ 5 = {
       Description: Chassis Fan 5
       Status: 0x00000009 [ PRESENT,F2B ]
       Caps:   0x00000038 [ SET_PERCENTAGE,GET_RPM,GET_PERCENTAGE ]
       RPM:    17700
       Per:    98
       Model:  NULL
       SN:     NULL
   }
   fan @ 6 = {
       Description: Chassis Fan 6
       Status: 0x00000009 [ PRESENT,F2B ]
       Caps:   0x00000038 [ SET_PERCENTAGE,GET_RPM,GET_PERCENTAGE ]
       RPM:    17700
       Per:    98
       Model:  NULL
       SN:     NULL
   }

Robin Bandura

unread,
May 19, 2021, 6:08:35 PMMay 19
to opennetworklinux
could you solve the problem ?
Reply all
Reply to author
Forward
0 new messages