ONL installation problem

43 views
Skip to first unread message

Ali Modarresi

unread,
Nov 29, 2020, 2:28:42 AM11/29/20
to opennetworklinux
Hi everyone

I am building ONL for AS5912-54x board. When I build ONL for the first time and install the binary file on board there is problem. But the next time I am running make clean at REPO repository and build it after that I am getting error while I am trying to install it on board.

Here is the installation log: 


[ boot-config ]
NETDEV=ma1
BOOTMODE=INSTALLED
SWI=images::latest


Press Control-C now to enter the interactive loader shell.

[ Starting Autoboot ]
[ Configuring Interfaces ]
[   12.070270] IPv6: ADDRCONF(NETDEV_UP): ma1: link is not ready
[   12.076707] 8021q: adding VLAN 0 to HW filter on device ma1
[   12.083093] ip (1580) used greatest stack depth: 13008 bytes left
[ BOOTMODE is installed. ]
DEBUG:swiget:+ blkid
INFO:swiget:found 'latest' swi /mnt/onl/images/ONL-master_ONL-OS8_2020-07-19.0645-11ed214_AMD64.swi
[ Un-populated /mnt/onl/data, will (re-)image ]
extracting SWI /mnt/onl/images/ONL-master_ONL-OS8_2020-07-19.0645-11ed214_AMD64.swi --> /mnt/onl/data/swiprep-pSvjuK
[   13.720372] igb 0000:00:14.0 ma1: igb: ma1 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX
[   13.730286] IPv6: ADDRCONF(NETDEV_CHANGE): ma1: link becomes ready
extracting rootfs /mnt/onl/data/swiprep-pSvjuK/rootfs.sqsh --> /mnt/onl/data
Parallel unsquashfs: Using 4 processors
12718 inodes (14640 blocks) to write


FATAL ERROR:create_inode: failed to create hardlink, because No such file or directory
*** invalid squashfs contents
recording SWI /mnt/onl/images/ONL-master_ONL-OS8_2020-07-19.0645-11ed214_AMD64.swi --> /tmp/swiprep-8QW1ch
[ Trying dir:data:/... ]
creating 1048576k of tmpfs in /tmp/boot-tmpfs-u81V7p
Mounting dir:data:/
DEBUG:swimount:+ blkid
DEBUG:swimount:+ ubinfo -a
ubinfo: error!: UBI is not present in the system
DEBUG:swimount:+ mount -o rw,rem[   17.358066] EXT4-fs (sda7): re-mounted. Opts: data=ordered
ount /mnt/onl/data
Switching rootfsmount: mounting /proc on /newroot/proc failed: No such file or directory
mount: mounting /sys on /newroot/sys failed: No such file or directory
mount: mounting /dev on /newroot/dev failed: No such file or directory
mount: mounting devtmpfs on /dev failed: Device or resource busy
[   21.537172] EXT4-fs (sda6): mounted filesystem with ordered data mode. Opts: (null)
[   21.556486] EXT4-fs (sda4): mounted filesystem with ordered data mode. Opts: (null)
[   21.571760] EXT4-fs (sda5): mounted filesystem with ordered data mode. Opts: (null)
mount: mounting proc on /proc failed: Device or resource busy
mount: mounting sysfs on /sys failed: Device or resource busy
initrng: Linux Random Number Generator (RNG) early init
INFO:onl-mounts:Running fsck on ONL-IMAGES [ /dev/sda6 ]...
INFO:onl-mounts:/dev/sda6 [ ONL-IMAGES ] is clean.
ERROR:onl-mounts:ONL-DATA (/dev/sda7) is mounted.
INFO:onl-mounts:Running fsck on ONL-BOOT [ /dev/sda4 ]...
INFO:onl-mounts:/dev/sda4 [ ONL-BOOT ] is clean.
INFO:onl-mounts:Running fsck on ONL-CONFIG [ /dev/sda5 ]...
INFO:onl-mounts:/dev/sda5 [ ONL-CONFIG ] is clean.
INFO:PKI:Using existing private key.
INFO:PKI:Using existing certificate.
************************************************************
*
* Open Network Linux Loader
*
*        Version: ONL-master
*             Id: 2020-07-19.06:45-11ed214
*
*       Platform: x86-64-accton-as5912-54x-r0
*            ma1: a8:2b:b5:8f:6b:a4
*
************************************************************
[ boot-config ]
NETDEV=ma1
BOOTMODE=INSTALLED
SWI=images::latest


Press Control-C now to enter the interactive loader shell.

[ Starting Autoboot ]
[ Configuring Interfaces ]
[ BOOTMODE is installed. ]

************************************************************
 ERROR

 Unmounted /mnt/onl/data, disk boot cannot continue

************************************************************


************************************************************
 ERROR

 The installed boot handler indicates an unrecoverable error. Autobooting cannot continue.

************************************************************


Welcome to the   shell.
Type 'help' for command help.

loader#




thanks to all
Reply all
Reply to author
Forward
0 new messages