Troubleshooting openhim install

Skip to first unread message

Ryan Yates

Feb 9, 2015, 3:50:10 PM2/9/15

I am trying to troubleshoot an OpenHIM install problem.  When trying to login to the openhim-console,  I get the following error message: "A server-side error has occurred. Please contact the server administrator".  I have tried the suggested fix here with the same results.  I am running openhim-core 1.0.0 and openhim-console 1.0.0.  I have installed openhim-console-1.0.0 from source and the tar file and had the same problem.  If it does matter I also have openhim-mediator-xds running as well and it appears to be working after I solved the cert issue with it connecting to the openhim. All of these are running on the same box.

Where should I start with troubleshooting this?  

Ryan Yates

Martin Brocker

Feb 10, 2015, 1:23:35 AM2/10/15
to Ryan Yates,
Hi Ryan

Thank you for your query. 

If you receive the above mentioned error on the login screen it could be as a result of a few things. First, Make sure that both Core and Console is up and running. You will also need make sure that the configuration in console is setup to point to the Core ( If all this is correct the the next step is to make sure that you've accepted the server certificate. 

Let us know if you run into any more problems and we'll get back to you as soon as possible.

Warm Regards,

You received this message because you are subscribed to the Google Groups "Interoperability Layer (OpenHIE)" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
For more options, visit

Ryan Yates

Feb 11, 2015, 9:28:00 AM2/11/15
to Martin Brocker,

The console is up and running and I can access the login page.  The core is up and running and accessible on port 8080.  Before compiling the console I edited appConfig.js, which looks like it serves the same purpose as default.json from master?  I have set the HOST variable to localhost.  Does this have to be a fqdn or will localhost work?  I have accepted the certificate on my browser and am able to go to https://server:8080

Ryan Crichton

Feb 11, 2015, 9:32:01 AM2/11/15
to Ryan Yates, Martin Brocker,
Hi Ryan,

On console the appConfig.js needs to be a fqdn of the core server as the console is a javascript app that get downloaded to your browser and run. it uses the core API so it needs to know where the core instance is located (it's public fqdn).

Ryan Crichton
Lead Developer, Jembi Health Systems  SOUTH AFRICA
Mobile: +27845829934 | Skype: ryan.graham.crichton

Ryan Yates

Feb 11, 2015, 10:01:51 AM2/11/15
to Ryan Crichton, Martin Brocker,
Thank You! Changing the HOST to the fqdn worked and I am now able to access the console.  If the fqdn is necessary then how does the openhim-console.tar.gz release work?  It there a way to configure the HOST in there? 

Also, the openhim-mediator-xds is taking up 99% CPU.  It appears to be working correctly and this is what is output.

[INFO] [02/11/2015 09:50:11.302] [main] [main] Initializing mediator server...
[INFO] [02/11/2015 09:50:11.373] [main] [main] Starting HTTP server...
[INFO] [02/11/2015 09:50:11.391] [main] [main] xds-mediator listening on
[INFO] [02/11/2015 09:50:11.448] [] [akka://mediator/user/xds-mediator] Registering mediator with core...
[INFO] [02/11/2015 09:50:11.454] [] [akka://mediator/user/xds-mediator/core-api-connector] Registering mediator with core...
[INFO] [02/11/2015 09:50:14.658] [] [akka://mediator/user/xds-mediator] Sent mediator registration message to core
[INFO] [02/11/2015 09:50:14.658] [] [akka://mediator/user/xds-mediator] Response: 201 (Created)

Hannes Venter

Feb 11, 2015, 1:05:52 PM2/11/15
to Ryan Yates, Ryan Crichton, Martin Brocker,
Ouch 99%! The mediator's definitely not supposed to do that. You wouldn't mind just trying the latest version that's in master to see if it makes a difference?

Yes, that output looks good: you should see in the HIM console that its created the necessary channels for itself.

Hannes Venter
Senior Software Developer, Jembi Health Systems |  SOUTH AFRICA
Mobile: +27 73 276 2848 | Office: +27 21 701 0939 | Skype: venter.johannes

Ryan Yates

Feb 11, 2015, 1:35:19 PM2/11/15
to Hannes Venter, Ryan Crichton, Martin Brocker,
Hmm just tried out the newest version and I am having the same issue.  Maybe due to openjdk?  I am using OpenJDK 1.7.0_75 on Ubuntu 14.04 64-bit. 

Carl Leitner

Feb 11, 2015, 1:36:23 PM2/11/15
to Hannes Venter, Ryan Yates, Ryan Crichton, Martin Brocker,, Justin Fyfe, ally shaban
Hey.  We had a CPU spike as well running the OpenHIM.  I am not sure if this was the same issue or not. (@Justin - did you happen to look?)

Justin Fyfe

Feb 11, 2015, 2:57:40 PM2/11/15
to Carl Leitner, Hannes Venter, Ryan Yates, Ryan Crichton, Martin Brocker,, ally shaban

I noticed that yesterday when the machine locked up… They appear to be normal now.

Hannes Venter

Feb 12, 2015, 2:04:17 AM2/12/15
to Justin Fyfe, Carl Leitner, Ryan Yates, Ryan Crichton, Martin Brocker,, ally shaban
Afraid I haven't been able to reproduce it on my side yet, both on my local system using the oracle jdk (1.8.0_25) and on an Ubuntu VM using the same version of the openjdk (1.7.0_75). The process is idling pretty happily.
Will keep looking into this and feedback.

Reply all
Reply to author
0 new messages