Upgrading the PHP version

12 views
Skip to first unread message

Thijs Kinkhorst

unread,
May 22, 2019, 4:25:23 AM5/22/19
to OpenConext Community
Hi all,

As probably known the only "supported" PHP version for the OpenConext
platform is currently PHP 5.6. This obviously is starting to show its age,
not only re upstream support but also increasingly libraries are starting
to drop support for it meaning we cannot upgrade to newer versions of
those libraries.

(The PHP apps are Engineblock, Profile and the whole of Stepup.)

Next to solving the support issues with 5.6, upgrading to a 7+ version of
PHP also brings new language features that we can use and it has improved
performance.

I've investigated our options. I think it's reasonable to upgrade to PHP
7.3. This is the most recent PHP stable version and has seen a number of
point updates so is also not completely brand new. It makes sense to me
that if we upgrade, we do it to a version that is as modern as possible.

For OpenConext-deploy I've created a PR that will install 7.3 alongside
5.6 so it's easy to switch applications one by one, so no big bang
migrations are needed. Basically just tweak a line in the virtual host
configration to use a different socket.

There's then an open question whether if we support 7.3 that would at the
same time also be the minimum required version.

If we go with 7.3 then this will be the version that OpenConext-deploy
uses and that at least we will be using and testing against. I think we
can then reasonably say that this is the best version to use. So it makes
sense to me to say that you need to have PHP 7.3. Just like now we say you
need PHP 5.6.

Let me know your ideas about this.


Kind regards,
Thijs


Niels van Dijk

unread,
May 22, 2019, 4:41:27 AM5/22/19
to openc...@googlegroups.com
Hi Thijs

Would/Should this also include updating PHP version for the stepup
components of OpenConext?

Niels
--
Niels van Dijk Technical Product Manager Trust & Security
Mob: +31 651347657 | Skype: cdr-80 | PGP Key ID: 0xDE7BB2F5
SURFnet BV | PO.Box 19035 | NL-3501 DA Utrecht | The Netherlands
www.surfnet.nl www.openconext.org


signature.asc

Thijs Kinkhorst

unread,
May 22, 2019, 4:45:31 AM5/22/19
to openc...@googlegroups.com
Op 22-05-19 om 10:41 schreef Niels van Dijk:
> Would/Should this also include updating PHP version for the stepup
> components of OpenConext?

The reasons that PHP 5.6 should be phased out for Engineblock apply
equally to Stepup.


Cheers,
Thijs

Niels van Dijk

unread,
May 22, 2019, 4:49:27 AM5/22/19
to openc...@googlegroups.com
Indeed,

So may I assume the php version for all of the platform (engine and
related and stepup) will all be upgraded to the same version in 1
'major' upgrade?

Niels
signature.asc

Thijs Kinkhorst

unread,
May 22, 2019, 4:52:53 AM5/22/19
to openc...@googlegroups.com
Op 22-05-19 om 10:49 schreef Niels van Dijk:
> So may I assume the php version for all of the platform (engine and
> related and stepup) will all be upgraded to the same version in 1
> 'major' upgrade?

No, as I wrote it is perfectly possible to switch applications one by one
from 5.6 to 7.3.


Cheers,
Thijs

Niels van Dijk

unread,
May 22, 2019, 4:55:18 AM5/22/19
to openc...@googlegroups.com
Ah sorry, missed that.

Thanks, Niels
signature.asc

Tim van Dijen

unread,
May 22, 2019, 6:58:54 AM5/22/19
to OpenConext Community
Just to let you know, I've recently migrated my demo-environment to PHP 7.3 (remi repository) and have experienced random crashes of php-fpm that I haven't been able to resolve yet.
7.2 works like a charm though..

Op woensdag 22 mei 2019 10:25:23 UTC+2 schreef Thijs Kinkhorst:

Thijs Kinkhorst

unread,
Jun 17, 2019, 11:05:23 AM6/17/19
to openc...@googlegroups.com
Op 22-05-19 om 12:58 schreef Tim van Dijen:
> Just to let you know, I've recently migrated my demo-environment to PHP
> 7.3 (remi repository) and have experienced random crashes of php-fpm that
> I haven't been able to resolve yet.
> 7.2 works like a charm though..

Thanks Tim.

We've done some assessments and we're currently going for an upgrade to
PHP 7.2.

This is mainly because we can likely do this in a way in which the
software (for a limited time) remains also compatible with 5.6. So that we
can do the upgrade in a small step and not a big-bang where we instantly
lose backwards compatibility.

We will be dropping support for 5.6 not long after though.


Cheers,
Thijs

signature.asc
Reply all
Reply to author
Forward
0 new messages