OSF3.4 Install on Centos7 and Ubuntu 14

34 views
Skip to first unread message

Kitio Fofack

unread,
Jun 21, 2017, 2:52:48 PM6/21/17
to Open Semantic Framework
I'm having so much trouble with the OSF install on Centos 7 and Ubuntu 14 !

Please find attached my log.xml files for both OSes. 

On Ubuntu I was able to complete the installation of OSF and OSF for drupal but I've never been able to connect to the end point.

Seem's like at some point tehre are users groups missing on virtuoso.

On Centos 7 the install stops right after virtoso install completes.

I hope it will help improving that release. In the mean time if anybody has a clue for me I will be happy to hear about it.

Regards


log_Centos_7.xml
log_ubuntu_14.xml

Kitio Fofack

unread,
Jun 22, 2017, 2:31:52 PM6/22/17
to Open Semantic Framework
I've been able to complete the installation on Ubuntu 14 buy making sure to configure the installer before launching it with:

./osf-installer -c  (for OSF backend ) and 

./osf-installer -d (for OSF dor drupal) 

Frederick Giasson

unread,
Jun 25, 2017, 9:05:47 PM6/25/17
to open-semant...@googlegroups.com
Hi Kitio,

> I've been able to complete the installation on Ubuntu 14 buy making
> sure to configure the installer before launching it with:
>
> ./osf-installer -c (for OSF backend ) and
>
> ./osf-installer -d (for OSF dor drupal)

Great that you found the issue and that you have been able to deploy it
as expected!

Thanks,

Take care,

Fred

Kitio Fofack

unread,
Jun 27, 2017, 10:32:51 AM6/27/17
to Open Semantic Framework
Hello Fred,

My happiness was short I think I have an issue related to the dnsname I gave to the server but I'm unable to understand where it comes from.

Would you please help me figure it out ?

When I validate an OSF API endpoint here is what I get : 

And Here is the debug message I can get from Drupal: 


Thanks in advance.

Le mercredi 21 juin 2017 14:52:48 UTC-4, Kitio Fofack a écrit :

Frederick Giasson

unread,
Jul 1, 2017, 8:46:01 PM7/1/17
to open-semant...@googlegroups.com
Hi Kitio,

Apparently that you are trying to access a dataset that is not
registered in your OSF instance
"http://osf-backend-server.ddns.uqam.ca/wsf/" as per this message error:
"You are trying to access a dataset that is not registered in OSF".

You should use the DMT (dataset management tool) to manage these
permissions and check what exists where.

Hope it helps,

Thanks,

Fred
/

/


Reply all
Reply to author
Forward
0 new messages