[PATCH] scsi:iscsi: rename iscsi_set_param to iscsi_if_set_param

2 views
Skip to first unread message

Wenchao Hao

unread,
Nov 21, 2022, 11:55:41 PM11/21/22
to Lee Duncan, Chris Leech, Mike Christie, James E . J . Bottomley, Martin K . Petersen, open-...@googlegroups.com, linux...@vger.kernel.org, linux-...@vger.kernel.org, liuzhi...@huawei.com, linfe...@huawei.com, Wenchao Hao
There are two iscsi_set_param() functions individually defined
in libiscsi.c and scsi_transport_iscsi.c which is confused.

So rename the one in scsi_transport_iscsi.c to iscsi_if_set_param().

Signed-off-by: Wenchao Hao <haowe...@huawei.com>
---
drivers/scsi/scsi_transport_iscsi.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/scsi/scsi_transport_iscsi.c b/drivers/scsi/scsi_transport_iscsi.c
index cd3db9684e52..c3fe5ecfee59 100644
--- a/drivers/scsi/scsi_transport_iscsi.c
+++ b/drivers/scsi/scsi_transport_iscsi.c
@@ -2988,7 +2988,7 @@ iscsi_if_destroy_conn(struct iscsi_transport *transport, struct iscsi_uevent *ev
}

static int
-iscsi_set_param(struct iscsi_transport *transport, struct iscsi_uevent *ev)
+iscsi_if_set_param(struct iscsi_transport *transport, struct iscsi_uevent *ev)
{
char *data = (char*)ev + sizeof(*ev);
struct iscsi_cls_conn *conn;
@@ -3941,7 +3941,7 @@ iscsi_if_recv_msg(struct sk_buff *skb, struct nlmsghdr *nlh, uint32_t *group)
err = -EINVAL;
break;
case ISCSI_UEVENT_SET_PARAM:
- err = iscsi_set_param(transport, ev);
+ err = iscsi_if_set_param(transport, ev);
break;
case ISCSI_UEVENT_CREATE_CONN:
case ISCSI_UEVENT_DESTROY_CONN:
--
2.35.3

Mike Christie

unread,
Nov 22, 2022, 11:55:11 AM11/22/22
to Wenchao Hao, Lee Duncan, Chris Leech, James E . J . Bottomley, Martin K . Petersen, open-...@googlegroups.com, linux...@vger.kernel.org, linux-...@vger.kernel.org, liuzhi...@huawei.com, linfe...@huawei.com
Reviewed-by: Mike Christie <michael....@oracle.com>

Lee Duncan

unread,
Nov 22, 2022, 2:53:21 PM11/22/22
to Wenchao Hao, Chris Leech, Mike Christie, James E . J . Bottomley, Martin K . Petersen, open-...@googlegroups.com, linux...@vger.kernel.org, linux-...@vger.kernel.org, liuzhi...@huawei.com, linfe...@huawei.com
Reviewed-by: Lee Duncan <ldu...@suse.com>

Martin K. Petersen

unread,
Nov 23, 2022, 10:27:52 PM11/23/22
to Wenchao Hao, Lee Duncan, Chris Leech, Mike Christie, James E . J . Bottomley, Martin K . Petersen, open-...@googlegroups.com, linux...@vger.kernel.org, linux-...@vger.kernel.org, liuzhi...@huawei.com, linfe...@huawei.com

Wenchao,

> There are two iscsi_set_param() functions individually defined in
> libiscsi.c and scsi_transport_iscsi.c which is confused.

Applied to 6.2/scsi-staging, thanks!

--
Martin K. Petersen Oracle Linux Engineering

Martin K. Petersen

unread,
Nov 30, 2022, 10:45:54 PM11/30/22
to Mike Christie, James E . J . Bottomley, Chris Leech, linux...@vger.kernel.org, Wenchao Hao, Lee Duncan, open-...@googlegroups.com, Martin K . Petersen, linux-...@vger.kernel.org, linfe...@huawei.com, liuzhi...@huawei.com
On Tue, 22 Nov 2022 18:11:05 +0000, Wenchao Hao wrote:

> There are two iscsi_set_param() functions individually defined
> in libiscsi.c and scsi_transport_iscsi.c which is confused.
>
> So rename the one in scsi_transport_iscsi.c to iscsi_if_set_param().
>
>

Applied to 6.2/scsi-queue, thanks!

[1/1] scsi:iscsi: rename iscsi_set_param to iscsi_if_set_param
https://git.kernel.org/mkp/scsi/c/0c26a2d7c980
Reply all
Reply to author
Forward
0 new messages