audio artifact / rollback version

25 views
Skip to first unread message

Nelson Totah

unread,
Dec 13, 2021, 8:18:41 AM12/13/21
to Open Ephys
Hi, 
We recently upgraded to v0.5.5.3 and now we have a periodic popping noise and overall lower quality audio. Same laptop, configuration, etc. The audio quality is poor enough that we cannot do recordings. However, the recorded data appears to be artifact free and good quality. I'd like to try to roll back to an earlier version. Can you tell me how to do that?

Josh Siegle

unread,
Dec 13, 2021, 2:18:07 PM12/13/21
to Nelson Totah, Open Ephys
Hmm, that’s strange as I don’t believe there were any audio-related changes in this release.

In any case, downgrading is easy – .zip files and installers for all previous releases are available on GitHub, e.g. see v0.5.5.2 here.

The next release (v0.6.0) *will* have some major changes to audio monitoring, including a dedicated Audio Monitor plugin with built-in high-pass filtering, a simpler channel selection UI, and the ability to select electrodes to listen to via the Spike Viewer. We will put out test binaries for this release later this week.

Josh



On Dec 13, 2021, at 5:18 AM, Nelson Totah <nelson...@gmail.com> wrote:

Hi, 
We recently upgraded to v0.5.5.3 and now we have a periodic popping noise and overall lower quality audio. Same laptop, configuration, etc. The audio quality is poor enough that we cannot do recordings. However, the recorded data appears to be artifact free and good quality. I'd like to try to roll back to an earlier version. Can you tell me how to do that?

--
You received this message because you are subscribed to the Google Groups "Open Ephys" group.
To unsubscribe from this group and stop receiving emails from it, send an email to open-ephys+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/open-ephys/d5d577bb-af85-442b-aab3-fcc0041fc02fn%40googlegroups.com.

nelson...@gmail.com

unread,
Dec 13, 2021, 2:42:15 PM12/13/21
to Josh Siegle, Open Ephys

Hi Josh

Thanks for your reply. It is indeed strange. We have 3 open ephys set-ups around in the building (different labs) and I heard this sound on one other system before and had no idea why it was happening. We will try to rollback the GUI version and report back to you all.

 

Thanks,

Nelson

nelson...@gmail.com

unread,
Dec 14, 2021, 6:59:06 AM12/14/21
to Josh Siegle, Open Ephys

Hi Josh,

 

New headstage, new cable, new port (each tested individually) running newest version 0.5.5.3 did not help the situation. There is popping which you can hear in this video: https://www.dropbox.com/s/sgs4ehctngqv35f/popping_OEv553_2021-12-14_11-43-42-949_.mp4?dl=0

 

Here is a video showing both popping and fading in / fading out of sound. https://www.dropbox.com/s/q6wgjluj4eco9ps/fadeout_20Off_20tap_20off_OEv553_2021-12-14_11-56-49-321_.mp4?dl=0

From time = 20 sec to 40 sec, we are repetitively tapping lightly on the rat’s back, which should generate a multi-unit response; however, the tapping causes a fading out of the sound which gradually recovers after the tapping stops. It also makes the popping louder. But, note that the popping gets louder during the tapping but it is not synchronized with the tapping. The popping also occurs in the first video when there is no tapping.

 

Now we rolled back to version 0.5.4. Everything is back to normal. Here is a video. We do the tapping from time = 10 sec to 20 sec.

https://www.dropbox.com/s/2yk1qqfqgj1j99b/good_OEv054_2021-12-14_12-41-20-016_.mp4?dl=0

 

We didn’t try other versions, but I think we had 0.5.5.1 earlier and it was also OK. The problem may have just been with 5.5.3.

 

So, it is good that we solved the problem. Let me know if we can do anything to help figure out what happened.

 

Nelson

Josh Siegle

unread,
Dec 15, 2021, 7:11:13 PM12/15/21
to nelson...@gmail.com, Open Ephys
Thanks for this info, it’s all very helpful!

We will investigate this further to see if we can figure out exactly what changes were responsible for this issue.

Josh
Reply all
Reply to author
Forward
0 new messages