Periodic build Koa CI: Failed

8 views
Skip to first unread message

OpenCraft

unread,
Sep 6, 2021, 10:12:22 PM9/6/21
to open-edx-btr-...@googlegroups.com
The periodic deployment of open-release/koa.master failed. Please see the details below.

Ansible task name: Gathering Facts
Relevant log lines:
{'changed': True,
'cmd': ['pip', 'install', '-r', 'requirements.txt'],
'delta': '[Filtered data]',
'end': '[Filtered data]',
'msg': 'non-zero return code',
'rc': 1,
'start': '[Filtered data]',
'stderr': 'Command "python setup.py egg_info" failed with error code 1 in '
'/tmp/pip-install-3_46y6ld/pygithub/\n'
'You are using pip version 19.0.3, however version 21.2.4 is '
'available.\n'
"You should consider upgrading via the 'pip install --upgrade pip' "
'command.',
'stderr_lines': ['Command "python setup.py egg_info" failed with error code 1 '
'in /tmp/pip-install-3_46y6ld/pygithub/',
'You are using pip version 19.0.3, however version 21.2.4 is '
'available.',
"You should consider upgrading via the 'pip install "
"--upgrade pip' command."],
'stdout': '[Filtered data]',
'stdout_lines': ['[Filtered data]',
'[Filtered data]',
' Installing build dependencies: started',
' Installing build dependencies: finished with status '
"'done'",
' Getting requirements to build wheel: started',
' Getting requirements to build wheel: finished with status '
"'done'",
' Preparing wheel metadata: started',
" Preparing wheel metadata: finished with status 'done'",
'Collecting authlib==0.15.4 (from -r requirements/base.txt '
'(line 9))',
' Downloading '
'https://files.pythonhosted.org/packages/08/8b/620a5ca21892520b0abdf3f6300ef0133d956a38565396c2fa487bf57e6f/Authlib-0.15.4-py2.py3-none-any.whl '
'(203kB)',
'Collecting backoff==1.5.0 (from -r requirements/base.txt '
'(line 11))',
' Downloading '
'https://files.pythonhosted.org/packages/99/c2/e8309fc7a635132df5731ec52a95bf9edee9d0214cafef22d2855a99748e/backoff-1.5.0.tar.gz',
'Collecting boto3==1.18.28 (from -r requirements/base.txt '
'(line 13))',
' Downloading '
'https://files.pythonhosted.org/packages/ce/1b/916f714db7855d188f622e7b85297d10b42fd59ff0483a034d4e3583df53/boto3-1.18.28-py3-none-any.whl '
'(131kB)',
'Collecting boto==2.43.0 (from -r requirements/base.txt '
'(line 15))',
' Downloading '
'https://files.pythonhosted.org/packages/29/64/51e30f48b0e160d384d13aeab66d416b68e404525a34a87aded0da82f32a/boto-2.43.0-py2.py3-none-any.whl '
'(1.3MB)',
'Collecting botocore==1.21.28 (from -r requirements/base.txt '
'(line 17))',
' Downloading '
'https://files.pythonhosted.org/packages/e6/ec/8b59342b73ccd0802ea2c79741e12506ee4ebce4ce0c639dafc8a53e2bed/botocore-1.21.28-py3-none-any.whl '
'(7.8MB)',
'Collecting cachetools==4.2.2 (from -r requirements/base.txt '
'(line 21))',
' Downloading '
'https://files.pythonhosted.org/packages/bf/28/c4f5796c67ad06bb91d98d543a5e01805c1ff065e08871f78e52d2a331ad/cachetools-4.2.2-py3-none-any.whl',
'Collecting certifi==2021.5.30 (from -r '
'requirements/base.txt (line 23))',
' Downloading '
'https://files.pythonhosted.org/packages/05/1b/0a0dece0e8aa492a6ec9e4ad2fe366b511558cdc73fd3abc82ba7348e875/certifi-2021.5.30-py2.py3-none-any.whl '
'(145kB)',
'Collecting cffi==1.14.6 (from -r requirements/base.txt '
'(line 27))',
' Downloading '
'https://files.pythonhosted.org/packages/80/a8/1562ce87c8cb8c736cbef40bc235f4a2ac7835822c231f717e3064dfcc93/cffi-1.14.6-cp38-cp38-manylinux1_x86_64.whl '
'(411kB)',
'Collecting charset-normalizer==2.0.4 (from -r '
'requirements/base.txt (line 29))',
' Downloading '
'https://files.pythonhosted.org/packages/33/53/b7f6126a2b9fd878b025fe3c40266cfaad696f312165008ce045bffa3fe7/charset_normalizer-2.0.4-py3-none-any.whl',
'Collecting click-log==0.3.2 (from -r requirements/base.txt '
'(line 31))',
' Downloading '
'https://files.pythonhosted.org/packages/38/52/a9dbb622f40ceeb09df141d855062cc9fbb38011f0ad8caee0cd840f399c/click_log-0.3.2-py2.py3-none-any.whl',
'Collecting click==8.0.1 (from -r requirements/base.txt '
'(line 33))',
' Downloading '
'https://files.pythonhosted.org/packages/76/0a/b6c5f311e32aeb3b406e03c079ade51e905ea630fc19d1262a46249c1c86/click-8.0.1-py3-none-any.whl '
'(97kB)',
'Collecting cloudflare==2.1.0 (from -r requirements/base.txt '
'(line 37))',
' Downloading '
'https://files.pythonhosted.org/packages/ea/44/910d1f5f1dde2f961c6ed667c2861cec20c1f5cb19a160ce1e6f558454a0/cloudflare-2.1.0.tar.gz '
'(53kB)',
'Collecting cryptography==3.4.8 (from -r '
'requirements/base.txt (line 39))',
' Downloading '
'https://files.pythonhosted.org/packages/28/d4/35dc171f470704403e35d639b1b4ad38f6a6e07c39aab2fad9437b88d4c3/cryptography-3.4.8-cp36-abi3-manylinux_2_12_x86_64.manylinux2010_x86_64.whl '
'(3.1MB)',
'Collecting decorator==5.0.9 (from -r requirements/base.txt '
'(line 41))',
' Downloading '
'https://files.pythonhosted.org/packages/6a/36/b1b9bfdf28690ae01d9ca0aa5b0d07cb4448ac65fb91dc7e2d094e3d992f/decorator-5.0.9-py3-none-any.whl',
'Collecting deprecated==1.2.12 (from -r '
'requirements/base.txt (line 43))',
' Downloading '
'https://files.pythonhosted.org/packages/fb/73/994edfcba74443146c84b91921fcc269374354118d4f452fb0c54c1cbb12/Deprecated-1.2.12-py2.py3-none-any.whl',
'Collecting easydict==1.9 (from -r requirements/base.txt '
'(line 47))',
' Downloading '
'https://files.pythonhosted.org/packages/4c/c5/5757886c4f538c1b3f95f6745499a24bffa389a805dee92d093e2d9ba7db/easydict-1.9.tar.gz',
'[Filtered data]',
'[Filtered data]',
'[Filtered data]',
'[Filtered data]',
'Collecting freezegun==0.3.8 (from -r requirements/base.txt '
'(line 53))',
' Downloading '
'https://files.pythonhosted.org/packages/0f/e9/c7d3ff0a0f1650dae522ac75bd1990c20a6fbf521385a8f6902b5d1f99f4/freezegun-0.3.8-py2.py3-none-any.whl',
'Collecting future==0.16.0 (from -r requirements/base.txt '
'(line 55))',
' Downloading '
'https://files.pythonhosted.org/packages/00/2b/8d082ddfed935f3608cc61140df6dcbf0edea1bc3ab52fb6c29ae3e81e85/future-0.16.0.tar.gz '
'(824kB)',
'Collecting gitdb==4.0.7 (from -r requirements/base.txt '
'(line 59))',
' Downloading '
'https://files.pythonhosted.org/packages/ea/e8/f414d1a4f0bbc668ed441f74f44c116d9816833a48bf81d22b697090dba8/gitdb-4.0.7-py3-none-any.whl '
'(63kB)',
'Collecting gitpython==3.1.18 (from -r requirements/base.txt '
'(line 61))',
' Downloading '
'https://files.pythonhosted.org/packages/bc/91/b38c4fabb6e5092ab23492ded4f318ab7299b19263272b703478038c0fbc/GitPython-3.1.18-py3-none-any.whl '
'(170kB)',
'[Filtered data]',
'[Filtered data]',
'Collecting google-auth-httplib2==0.1.0 (from -r '
'requirements/base.txt (line 65))',
' Downloading '
'https://files.pythonhosted.org/packages/ba/db/721e2f3f32339080153995d16e46edc3a7657251f167ddcb9327e632783b/google_auth_httplib2-0.1.0-py2.py3-none-any.whl',
'Collecting google-auth==2.0.1 (from -r '
'requirements/base.txt (line 67))',
' Downloading '
'https://files.pythonhosted.org/packages/b0/e2/940b73a4923b8659103bbabbf35d4fdeb11374f6bd47234f724238a6023b/google_auth-2.0.1-py2.py3-none-any.whl '
'(152kB)',
'Collecting httplib2==0.19.1 (from -r requirements/base.txt '
'(line 72))',
' Downloading '
'https://files.pythonhosted.org/packages/15/dc/d14bce03f4bfd0214b90a3f556d7c96f75bb94ad597c816a641b962f22e9/httplib2-0.19.1-py3-none-any.whl '
'(95kB)',
'Collecting idna==3.2 (from -r requirements/base.txt (line '
'76))',
' Downloading '
'https://files.pythonhosted.org/packages/d7/77/ff688d1504cdc4db2a938e2b7b9adee5dd52e34efbd2431051efc9984de9/idna-3.2-py3-none-any.whl '
'(59kB)',
'Collecting importlib-metadata==4.6.4 (from -r '
'requirements/base.txt (line 78))',
' Downloading '
'https://files.pythonhosted.org/packages/c0/72/4512a88e402d4dc3bab49a845130d95ac48936ef3a9469b55cc79a60d84d/importlib_metadata-4.6.4-py3-none-any.whl',
'[Filtered data]',
'[Filtered data]',
'Collecting jmespath==0.10.0 (from -r requirements/base.txt '
'(line 82))',
' Downloading '
'https://files.pythonhosted.org/packages/07/cb/5f001272b6faeb23c1c9e0acc04d48eaaf5c862c17709d20e3469c6e0139/jmespath-0.10.0-py2.py3-none-any.whl',
'Collecting jsonlines==2.0.0 (from -r requirements/base.txt '
'(line 86))',
' Downloading '
'https://files.pythonhosted.org/packages/d4/58/06f430ff7607a2929f80f07bfd820acbc508a4e977542fefcc522cde9dff/jsonlines-2.0.0-py3-none-any.whl',
'Collecting kubernetes==12.0.1 (from -r '
'requirements/base.txt (line 88))',
' Downloading '
'https://files.pythonhosted.org/packages/50/55/84aaadb5f8b4d2641f28eb7373feb610f4b609cc9cf223bcd494fd66a647/kubernetes-12.0.1-py2.py3-none-any.whl '
'(1.7MB)',
'Collecting lxml==4.6.3 (from -r requirements/base.txt (line '
'90))',
' Downloading '
'https://files.pythonhosted.org/packages/e5/d7/2d8b9e1d4fe05b8b72b3d2345d5a741b005640681482502b5ce3d8f020d4/lxml-4.6.3-cp38-cp38-manylinux1_x86_64.whl '
'(5.4MB)',
'Collecting oauthlib==3.1.1 (from -r requirements/base.txt '
'(line 92))',
' Downloading '
'https://files.pythonhosted.org/packages/e8/5d/9dd1c29e5a786525f6342f6c1d812ed2e37edc653ad297048c1668988053/oauthlib-3.1.1-py2.py3-none-any.whl '
'(146kB)',
'Collecting pbr==5.6.0 (from -r requirements/base.txt (line '
'96))',
' Downloading '
'https://files.pythonhosted.org/packages/18/e0/1d4702dd81121d04a477c272d47ee5b6bc970d1a0990b11befa275c55cf2/pbr-5.6.0-py2.py3-none-any.whl '
'(111kB)',
'Collecting pyasn1-modules==0.2.8 (from -r '
'requirements/base.txt (line 98))',
' Downloading '
'https://files.pythonhosted.org/packages/95/de/214830a981892a3e286c3794f41ae67a4495df1108c3da8a9f62159b9a9d/pyasn1_modules-0.2.8-py2.py3-none-any.whl '
'(155kB)',
'Collecting pyasn1==0.4.8 (from -r requirements/base.txt '
'(line 100))',
' Downloading '
'https://files.pythonhosted.org/packages/62/1e/a94a8d635fa3ce4cfc7f506003548d0a2447ae76fd5ca53932970fe3053f/pyasn1-0.4.8-py2.py3-none-any.whl '
'(77kB)',
'Collecting pycparser==2.20 (from -r requirements/base.txt '
'(line 104))',
' Downloading '
'https://files.pythonhosted.org/packages/ae/e7/d9c3a176ca4b02024debf82342dab36efadfc5776f9c8db077e8f6e71821/pycparser-2.20-py2.py3-none-any.whl '
'(112kB)',
'Collecting pygithub==1.43.8 (from -r requirements/base.txt '
'(line 106))',
' Downloading '
'https://files.pythonhosted.org/packages/13/66/5c510242526d162708ffc0c82fd5ba647886f07d7abcae8587adeec86411/PyGithub-1.43.8.tar.gz '
'(108kB)',
' Complete output from command python setup.py egg_info:',
' error in PyGithub setup command: use_2to3 is invalid.',
' ',
' ----------------------------------------']}

AppServer ID: 20587
Latest successful provision date: 2021-09-06 13:15:05.938348+00:00
Configuration source repo: https://github.com/edx/configuration.git
Configuration version: open-release/koa.master
OpenEdX platform source repo: https://github.com/edx/edx-platform.git
OpenEdX platform release: open-release/koa.master
OpenEdX platform commit: open-release/koa.master
build_log.json
configuration.json

OpenCraft

unread,
Sep 7, 2021, 12:22:02 PM9/7/21
to open-edx-btr-...@googlegroups.com
The periodic deployment of open-release/koa.master failed. Please see the details below.

Ansible task name: Gathering Facts
Relevant log lines:
{'changed': True,
'cmd': ['pip', 'install', '-r', 'requirements.txt'],
'delta': '[Filtered data]',
'end': '[Filtered data]',
'msg': 'non-zero return code',
'rc': 1,
'start': '[Filtered data]',
'stderr': 'Command "python setup.py egg_info" failed with error code 1 in '
'/tmp/pip-install-mdseomgt/pygithub/\n'
'You are using pip version 19.0.3, however version 21.2.4 is '
'available.\n'
"You should consider upgrading via the 'pip install --upgrade pip' "
'command.',
'stderr_lines': ['Command "python setup.py egg_info" failed with error code 1 '
'in /tmp/pip-install-mdseomgt/pygithub/',
AppServer ID: 20592
build_log.json
configuration.json

OpenCraft

unread,
Sep 9, 2021, 6:48:23 AM9/9/21
to open-edx-btr-...@googlegroups.com
The periodic deployment of open-release/koa.master failed. Please see the details below.

Ansible task name: user : Create the users
Relevant log lines:
{'github': True, 'name': 'jvdm', 'type': 'admin'}

AppServer ID: 20606
Latest successful provision date: 2021-09-09 10:48:20.556641+00:00
build_log.json
configuration.json

OpenCraft

unread,
Sep 16, 2021, 10:26:10 PM9/16/21
to open-edx-btr-...@googlegroups.com
The periodic deployment of open-release/koa.master failed. Please see the details below.

Ansible task name: Gathering Facts
Relevant log lines:
{'censored': "the output has been hidden due to the fact that 'no_log: true' "
'was specified for this result',
'changed': False}

AppServer ID: 20705
Latest successful provision date: 2021-09-16 12:47:35.870640+00:00
build_log.json
configuration.json

OpenCraft

unread,
Sep 17, 2021, 12:47:30 PM9/17/21
to open-edx-btr-...@googlegroups.com
The periodic deployment of open-release/koa.master failed. Please see the details below.

Ansible task name: Gathering Facts
Relevant log lines:
{'censored': "the output has been hidden due to the fact that 'no_log: true' "
'was specified for this result',
'changed': False}

AppServer ID: 20711
build_log.json
configuration.json

Jill Vogel

unread,
Sep 17, 2021, 9:50:51 PM9/17/21
to Open edX BTR Notifications
This failure was due to a misconfiguration on the instance, and should be fixed for the next build.

To work around the issue causing this failure, we're using a customized branch of edx/tubular for the koa periodic build instance.
This issue has been fixed in master and lilac.master.

OpenCraft

unread,
Sep 22, 2021, 5:43:15 PM9/22/21
to open-edx-btr-...@googlegroups.com
The periodic deployment of open-release/koa.master failed. Please see the details below.

Ansible task name: Change state of supervisord managed services
Relevant log lines:
{'changed': False, 'msg': 'ERROR (no such process)', 'name': 'edxapp_worker'}

AppServer ID: 20764
Latest successful provision date: 2021-09-22 09:13:36.062485+00:00
build_log.json
configuration.json

Jill Vogel

unread,
Sep 23, 2021, 12:05:42 AM9/23/21
to Open edX BTR Notifications
Seems to be a temporary issue with installing packages from npm?
Re-running npm install on the appserver ran successfully, so this should be fixed on the next build.


Partial Ansible output pasted below for reference.

2021-09-23 07:11:28+0930 INFO TASK [edxapp : install node dependencies] **************************************************************************************************
2021-09-23 07:11:28+0930 INFO Wednesday 22 September 2021 21:41:28 +0000 (0:00:00.656) 1:04:46.187 ***
2021-09-23 07:12:18+0930 INFO fatal: [213.32.77.134]: FAILED! => { "changed": true, "cmd": "easy_install --version && npm install", "delta": "0:00:49.174108", "end": "2021-09-22 21:42:18.075562", "msg": "non-zero return code", "rc": 1, "start": "2021-09-22 21:41:28.901454", "stderr_lines": [ "npm WARN tarball tarball data for edx-ui-...@1.5.2 (sha1-JOiIW84ffN+rFkeb/5IJ9jeTBkc=) seems to be corrupted. Trying one more time.", "npm WARN tarball tarball data for hls...@0.9.0 (sha512-YFklk/07BAIEZpI6V1HqjJ4VPOO7zLGcrgzJiiyp9HXK/KH7JDWZylNjT+hn52gfyhqzmagLpJoMXNATgsMBcw==) seems to be corrupted. Trying one more time.",
"npm WARN tar ENOENT: no such file or directory, lstat '/edx/app/edxapp/edx-platform/node_modules/.staging/karma-jasmine-html-reporter-a1243b48/src'", "npm WARN tar ENOENT: no such file or directory, lstat '/edx/app/edxapp/edx-platform/node_modules/.staging/which-country-1eac65f5/lib'",
....
"npm WARN tar ENOENT: no such file or directory, lstat '/edx/app/edxapp/edx-platform/node_modules/.staging/picturefill-05326927/tests'",
"npm WARN tar ENOENT: no such file or directory, lstat '/edx/app/edxapp/edx-platform/node_modules/.staging/picturefill-05326927/tests'", "", "npm ERR! A complete log of this run can be found in:", "npm ERR! /edx/app/edxapp/.npm/_logs/2021-09-22T21_42_17_784Z-debug.log" ], "stdout_lines": [ "setuptools 44.1.0 from /usr/local/lib/python3.8/dist-packages (Python 3.8)" ] }
Reply all
Reply to author
Forward
0 new messages