What did I do wrong?

131 views
Skip to first unread message

D4006

unread,
Jun 4, 2023, 5:51:48 AM6/4/23
to OneCommander
I lost my thumbnails in OneCommander. Here's a screenshot where I'm in thumbnail mode but not seeing any. On the left side you see regular Windows Explorer showing the same folder, with thumbnails. I didn't intentionally turn thumbnails off, but it is possible.


Screenshot 2023-06-04 115126.jpg

Milos Paripovic

unread,
Jun 4, 2023, 12:39:33 PM6/4/23
to OneCommander
Is that cloud folder? Does it show in other non-cloud locations? 

D4006

unread,
Jun 4, 2023, 2:03:00 PM6/4/23
to OneCommander
No, that's an internal SSD. Windows 11 laptop.

Milos Paripovic

unread,
Jun 4, 2023, 4:23:56 PM6/4/23
to OneCommander
Why does it have checkboxes in explorer? Does it show image thumbnails in any other folder? If you create a folder Temp in C:\ and then download some jpg web, does it show it there?
There is no option to turn off showing thumbnail so as long as Windows thumbnail handler works, OC should show thumbnails.

D4006

unread,
Jun 5, 2023, 2:23:00 AM6/5/23
to OneCommander
Those ticks in explorer were because that particular folder was synced via Dropbox, the ticks show those images are synced with my phone. But it was happening on all folders, not just that one.

I guess I'll never know now though, I had to reboot the machine (something I only do a couple of times a month) and now I'm seeing my OC thumbnails again. If it happens again, and I know why because as it appears I'll think back what I did prior to that, then I'll report back. Realistically I'll probably never see it again.

Thanks. You're doing great things with this essential tool :-)

Kyle Condon

unread,
Jun 8, 2023, 11:23:37 AM6/8/23
to OneCommander
I'll tag on here and say it won't show thumbnails for my cloud folders either, but they are always on the disk on a separate drive. I'm using the OC thumbnail cache. Is there a way to get thumbnails on Cloud Drives that are locally stored?

Kyle Condon

unread,
Jun 8, 2023, 11:28:55 AM6/8/23
to OneCommander
It also will load thumbnails for .ico files in my cloud drives, but nothing else.

Milos Paripovic

unread,
Jun 9, 2023, 11:58:52 AM6/9/23
to OneCommander
Try this:
1- Close program from system tray and reopen, then see if it shows thumbs before proceeding
2- Turn off Use Local Thumbnail Database from Settings>Advanced, and then again fully restart OC only by closing it first from system tray
3- Restart PC

ICO and EXE files will just get icons, while the rest will have to go through system thumbnail extractor. White Use Local Thumbnail database option will still use the same extraction, it doesn't go through intermediary, which is faster but one stuck thumb extraction may stop extracting all other thumbs until OC is restarted. At least that is an assumption as I am still not able to reproduce the issue, but if restarting fixes it, we can look for file that causes the system extractor to freeze

Message has been deleted

Kyle Condon

unread,
Jun 10, 2023, 12:55:39 AM6/10/23
to OneCommander
Nope didn't work on or off in cloud locations. Works in non cloud locations. Maybe when the cloud apps go to upload the files it blocks access from OneCommander?

Milos Paripovic

unread,
Jun 10, 2023, 10:46:40 PM6/10/23
to OneCommander
I have only tested it with built-in OneDrive in User folder and with Google Drive, and it is loading thumbnails. 
Make sure this is checked:
Advanced > Get thumbnails of cloud files

While cloud syncing software could block OC from getting thumbnails, program already has system to keep retrying to get thumbnail if cloud marks it as pending, so that shouldn't be an issue. But in that case it won't show the icons of those files as in your screenshot, so I am not sure why it is like this. Do you have some 3rd party thumbnail handler. I tested program in the past with SageThumbs and FastPictureViewer Codec Pack, I don't know if there are others that will not work with OC.

Kyle Condon

unread,
Jun 11, 2023, 11:16:54 AM6/11/23
to OneCommander
Hmm at first thumbs weren't showing in explorer either, but I did some dism and sfc and now they display in explorer. Still don't display in OC with or without those options enabled/disabled. In OC thumbs display in non Cloud locations but not cloud ones. Are you just using Windows APIs? I'm on the Windows 11 Insider Build Canary Channel so my setup may be using different syntax requirements than yours.

Milos Paripovic

unread,
Jun 11, 2023, 12:09:03 PM6/11/23
to OneCommander
Everything related are Windows APIs. They did ruin virtual desktop interfaces in the insider builds a few times so they might have changed interface for thumbnail handler but I doubt that is the case since you say it works for non-cloud thumbs. Did you check release notes for your particular build if there were any related notes for thumbnails? I can try updating some old machine at work to that insider build and see if there are issues.

Kyle Condon

unread,
Jun 11, 2023, 3:36:44 PM6/11/23
to OneCommander
Is there a thumbnail cache file in the OC folder I can manually delete?

Milos Paripovic

unread,
Jun 11, 2023, 11:40:17 PM6/11/23
to OneCommander
In Settings>Advanced, under the option to use Local Thumbnail Database there is a button  
Clear Local thumbnail database
Or deleting file "\Settings\Thumbnails.db" when OC is not running in the system tray.

But if the above option in not checked, then it is using Windows thumbnail database that can be cleared with 
Win + typing "cleanup" and checking Thumbnails in cleanup dialog

Kyle Condon

unread,
Jun 12, 2023, 12:37:30 AM6/12/23
to OneCommander
Got it working in windows now. Tried both suggestions but neither worked.

Kyle Condon

unread,
Jun 12, 2023, 12:39:35 AM6/12/23
to OneCommander
It's definitely adding entries to thumbnails.db because it increases in file size when I navigate to another folder with pictures.

Milos Paripovic

unread,
Jun 13, 2023, 12:10:10 AM6/13/23
to OneCommander
Are you using any non-native programs for cloud synchronization or using just regular OneDrive that comes with Windows?

I have made it log an error if there is one.
Please run this from a different folder
https://onecommander.com/OneCommander3.45.2.0.zip
Copy path to one of the cloud photos that is already synchronized
then press
Ctrl+shift+Alt+F1
and at the bottom of the dialog paste that path, scroll down to see if the images show up (if there is one, hover to see if it shows 1 or 2 in tooltip)
Then you can right-click on OC icon in tray and View Log to see if it shows any errors at the bottom
Reply all
Reply to author
Forward
0 new messages