Java 8 Support

22 views
Skip to first unread message

Eric Olson

unread,
Dec 18, 2017, 4:52:31 PM12/18/17
to onebusaway-users
Hello,

I am looking to confirm whether the current stable release (1.1.16) of OBA supports Java 8? Since Java 7 has been end-of-life since 2015, we are not comfortable using it. There is an open issue discussing this topic from 2015, but there does not appear to be an official confirmation here. Are other organizations successfully hosting OBA using Java 8?

We are attempting to setup a new OBA installation, and I am running into problems while trying to use Java 8. I'm not sure if the problems that we are having are related to Java 8, or are caused by something else that I am screwing up during the setup.

Thanks,

Eric Olson
City of Madison, Wisconsin

sjbarbeau

unread,
Dec 18, 2017, 4:58:56 PM12/18/17
to onebusaway-users
Eric,
Note that there is a 1.1.18 release:

I'm fairly certain that this supports Java 8, although I'm not currently running it myself.

Sean

sjbarbeau

unread,
Dec 18, 2017, 5:28:16 PM12/18/17
to onebusaway-users
Just talked to Sheldon from CS, he confirmed that it supports Java 8.

Sean

Reply all
Reply to author
Forward
0 new messages