"Unused entry" warning in omnetpp.ini when using the "like" keyword

1394 views
Skip to first unread message

Aniruddha

unread,
Jan 15, 2010, 9:01:43 AM1/15/10
to omnetpp
Hi folks,

I tried searching the list for answers but could not find one so I am
posting this basic question about the "Unused entry (does not match
any parameter)" warning I see in my omnetpp.ini file.

I am using the INETMANET framework. I took the TCPBasicAppClient.ned
(and its C++ header/impl files), and made my own class. So I now have
something like this:

simple MyTCPBasicClient like TCPApp {

// everything here including parameters, etc, is the same as
TCPBasicAppClient.ned from INETMANET.

}

I also added the @class to the parameters in the above simple module.

Now, in my example I have a WirelessHost and I want to set its
tcpAppType to be "MyTCPBasicClient" instead of "TCPBasicClientApp". In
the IDE, when I type something like this:

**.host*.tcpAppType =

and I press Control-Space to see what all choices are available, I see
the definition of the module I defined (in addition to the already
supported choices). So I select the "MyTCPBasicClient".

But now I get the Unused entry warning (yellow markers) for all the
parameters like port, connectAddress, etc.

Even then I tried to run my example and it runs properly. When I
inspect the host object, I see that it has all the parameters and the
values are set to what I specified in the omnetpp.ini file.

But then the question is why are those warning showing up and why are
those parameters not being matched? I am using the 4.0 version and
not the latest beta.

thanks
Aniruddha

Rudolf Hornig

unread,
Jan 16, 2010, 6:52:49 AM1/16/10
to omn...@googlegroups.com
Well, the IDE tries to do its best to guess and figure out what parameters you 
are using for your modules. This obviously depends on what module type you are using.
In this case the type was specified as a value of a parameter and the IDE simply cannot 
figure out it correctly as it is using only static analysis. There are much more complicated cases
where it is simply impossible to give a correct answer. for example

**.host[0].tcpAppType = MyTCPBasicClient
**.host[1].tcpAppType = TCPBasicClient

Let's assume that MyTCPBasicClient has a parameter myExtraPar while TCPBasicClient does not.


Now if you write
**.host[*].tcp.myExtraPar = ...

Is this parameter used or unused? well it is used for hos[0] but unused for host[1]...

In summary. This a false positive warning and you can safely ignore it. Maybe in later releases 
of omnet we will implement some basic dynamic type resolution.

But, there is no perfectoin :)

Rudolf


thanks
Aniruddha

--
You received this message because you are subscribed to the Google Groups "omnetpp" group.
To post to this group, send email to omn...@googlegroups.com.
To unsubscribe from this group, send email to omnetpp+u...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/omnetpp?hl=en.




Andras Varga

unread,
Jan 16, 2010, 1:48:18 PM1/16/10
to omn...@googlegroups.com
This should work. Would you mind submitting a bug report, with a
stripped-down example that we can use to reproduce the issue?
bugs.omnetpp.org

Thanks,
Andras

Aniruddha

unread,
Jan 16, 2010, 7:57:45 PM1/16/10
to omnetpp
Hi Andras, Rudolf,

Thanks for your inputs. I will submit a bug report.

Thanks
Aniruddha

Reply all
Reply to author
Forward
0 new messages