Can't install OMNeT++: stuck at configure

2413 views
Skip to first unread message

jkbecker

unread,
Feb 16, 2018, 5:07:17 PM2/16/18
to OMNeT++ Users
Getting stuck in ./configure with the following log (see below - tl;dr: "error: Cannot build Qt apps, probably due to missing or too old Qt packages. Make sure Qt development packages are installed and newer than Qt 5.4. You can disable Qtenv by setting the WITH_QTENV variable to "no" in configure.user.")

Needless to say, I did install all the prerequisites as per installation guide for linux; especially Qt is on the system:
~ $ qtchooser -print-env
QT_SELECT
="default"
QTTOOLDIR
="/usr/lib/x86_64-linux-gnu/qt5/bin"
QTLIBDIR
="/usr/lib/x86_64-linux-gnu"
~ $ qtchooser -list-versions
4
5
default
qt4
-x86_64-linux-gnu
qt4
qt5
-x86_64-linux-gnu
qt5

I tried installing more Qt-related stuff which didn't change anything. What am I missing?

I am trying to install omnetpp-5.2.1 and I am on the following system:

-Version-
Kernel        : Linux 4.10.0-38-generic (x86_64)
Compiled        : #42~16.04.1-Ubuntu SMP Tue Oct 10 16:32:20 UTC 2017
C
Library        : Unknown
Default C Compiler        : GNU C Compiler version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.6)
Distribution        : Linux Mint 18.3 Sylvia

## Here is the full log:


~/Code/install/omnetpp-5.2.1 $ ./configure
checking build system type
... x86_64-unknown-linux-gnu
checking host system type
... x86_64-unknown-linux-gnu
configure
: -----------------------------------------------
configure
: reading configure.user for your custom settings
configure
: -----------------------------------------------
checking
for clang... no
checking
for icc... no
checking
for gcc... gcc
checking whether the C compiler works
... yes
checking
for C compiler default output file name... a.out
checking
for suffix of executables...
checking whether we are cross compiling
... no
checking
for suffix of object files... o
checking whether we are
using the GNU C compiler... yes
checking whether gcc accepts
-g... yes
checking
for gcc option to accept ISO C89... none needed
checking
for clang++... no
checking
for clang... no
checking
for icpc... no
checking
for g++... g++
checking whether we are
using the GNU C++ compiler... yes
checking whether g
++ accepts -g... yes
checking
for g++... g++
checking
for ranlib... ranlib
checking whether g
++ supports -fno-stack-protector... yes
checking whether g
++ supports -Wl,--no-as-needed... yes
checking whether g
++ supports -Wl,--as-needed... yes
checking
for swapcontext... yes
checking
if shared libs need -fPIC... yes
checking
for dlopen with CFLAGS="" LIBS=""... no
checking
if --export-dynamic linker option is supported/needed... test failed
checking
for flags needed to link with static libs containing simple modules... --whole-archive
configure
: NOTE: Use the following syntax when linking with static libraries
configure
: containing simple modules and other dynamically registered components:
configure
:    g++ ... -Wl,--whole-archive <libs> -Wl,--no-whole-archive ...
checking whether linker supports
-rpath... yes
checking
for bison... bison -y
checking
for flex... flex
checking lex output file root
... lex.yy
checking lex library
... none needed
checking whether yytext
is a pointer... no
checking
for make... make
checking
for perl... perl
checking
for swig... not found
checking
for math with CFLAGS="" LIBS=""... yes
checking
for standard C++ lib with CFLAGS="" LIBS="-lstdc++"... yes
checking
for dlopen with CFLAGS="" LIBS=""... no
checking
for dlopen with CFLAGS="" LIBS="-ldl"... yes
checking
for qmake... /usr/bin/qmake
checking
for moc... /usr/bin/moc
checking
for uic... /usr/bin/uic
checking
for rcc... /usr/bin/rcc
checking
for Qt5 with CFLAGS=" -std=c++11  -fPIC -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtOpenGL -isystem /usr/include/x86_64-linux-gnu/qt5/QtPrintSupport  -fPIC -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtOpenGL -isystem /usr/include/x86_64-linux-gnu/qt5/QtPrintSupport" LIBS="-lQt5Gui -lQt5Core -lQt5Widgets -lQt5PrintSupport -lQt5OpenGL -L/usr/lib/x86_64-linux-gnu -Wl,-rpath=/usr/lib/x86_64-linux-gnu"... no
checking
for Qt5 with CFLAGS=" -std=c++11  -fPIC -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtOpenGL -isystem /usr/include/x86_64-linux-gnu/qt5/QtPrintSupport  -fPIC -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtOpenGL -isystem /usr/include/x86_64-linux-gnu/qt5/QtPrintSupport" LIBS="-lQtGui5 -lQtCore5 -lQtWidgets5 -lQtPrintSupport5 -lQtOpenGL5"... no
checking
for Qt5 with CFLAGS=" -std=c++11  -fPIC -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtOpenGL -isystem /usr/include/x86_64-linux-gnu/qt5/QtPrintSupport  -fPIC -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtOpenGL -isystem /usr/include/x86_64-linux-gnu/qt5/QtPrintSupport" LIBS=" -framework QtGui -framework QtCore -framework QtWidgets -framework QtPrintSupport -framework QtOpenGL"... no
configure
: error: Cannot build Qt apps, probably due to missing or too old Qt packages. Make sure Qt development packages are installed and newer than Qt 5.4. You can disable Qtenv by setting the WITH_QTENV variable to "no" in configure.user.

Attila Török

unread,
Feb 16, 2018, 5:19:07 PM2/16/18
to OMNeT++ Users
What exactly do you mean by "more Qt-related stuff"? Is the libqt5opengl5-dev package installed for example?
Also, the config.log file contains more useful info than the output of ./configure.
But please don't paste it into the email, either attach it or share it via an online pasting service (pastebin, gist, etc.).

Attila

--
You received this message because you are subscribed to the Google Groups "OMNeT++ Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to omnetpp+unsubscribe@googlegroups.com.
Visit this group at https://groups.google.com/group/omnetpp.
For more options, visit https://groups.google.com/d/optout.

jkbecker

unread,
Feb 16, 2018, 9:51:21 PM2/16/18
to OMNeT++ Users
Hi Attila,
thanks, installing libqt5opengl5-dev did the trick! This package is completely missing from the InstallGuide. Would it be the right approach to open an issue on the bug tracker or how is this usually handled? I had this problem 3 times before (once on ubuntu, once on CentOS and once on Debian) and then once I was successful installing it without issues - in that case I must have had libqt5opengl5-dev before from another dependency.
I would greatly appreciate if this could be added to the instructions. I can do that if that's how it is supposed to work... let me know.
Best
Johannes
To unsubscribe from this group and stop receiving emails from it, send an email to omnetpp+u...@googlegroups.com.

Attila Török

unread,
Feb 17, 2018, 5:32:39 AM2/17/18
to OMNeT++ Users
I'm glad it helped. You could have reported the issue the first time it came up, and we could have worked it out earlier. But later is better than never! :)
Thank you for your offer to help, but there is no need for a bug report, as I've already updated the InstallGuide internally. The change should be included in the next release.

Attila

To unsubscribe from this group and stop receiving emails from it, send an email to omnetpp+unsubscribe@googlegroups.com.

Saurabh Samber

unread,
Mar 6, 2018, 4:13:28 PM3/6/18
to OMNeT++ Users

Saurabh Samber

unread,
Mar 6, 2018, 4:15:34 PM3/6/18
to OMNeT++ Users
Can you tell i have exactly the same problem in windows platform


On Friday, February 16, 2018 at 11:07:17 PM UTC+1, jkbecker wrote:
Reply all
Reply to author
Forward
0 new messages