Parameters to communicate between car node and standard host

27 views
Skip to first unread message

Cheema

unread,
Jul 4, 2020, 5:44:21 AM7/4/20
to OMNeT++ Users
I want to communicate between a car node and standard host node. I'm using veins_inet car node. when I run my simulaton alot of parameters are asked e.g. analomodel,x- axis, y axis etc.
What parameters should I insert in my ini file.?
##############################My .ned file#######################

package testingFOG;

import inet.networklayer.configurator.ipv4.IPv4NetworkConfigurator;
import inet.node.ethernet.Eth100M;
import inet.node.inet.AdhocHost;
import inet.node.inet.Router;
import inet.node.inet.StandardHost;
import inet.node.inet.WirelessHost;
import inet.node.wireless.AccessPoint;
import inet.physicallayer.ieee80211.packetlevel.Ieee80211ScalarRadioMedium;
import inet.visualizer.contract.IIntegratedVisualizer;
import org.car2x.veins.nodes.Car;


network testingFOG
{
   
@display("bgb=500,300");
    submodules
:
        visualizer
: <default("IntegratedCanvasVisualizer")> like IIntegratedVisualizer if hasVisualizer() {
            parameters
:
               
@display("p=36,34");
       
}
        configurator
: IPv4NetworkConfigurator {
            parameters
:
                assignDisjunctSubnetAddresses
= false;
               
@display("p=36,83");
       
}
        radioMedium
: Ieee80211ScalarRadioMedium {
            parameters
:
               
@display("p=34,134");
       
}
       
//endNode: WirelessHost {  //wirelessHost1
       
//    parameters:
       
//        @display("p=246,111");
       
//}
        serverNode
: StandardHost {//wiredHost1
            parameters
:
               
@display("p=400,147;i=device/server");
       
}
       
//  wiredHost2: StandardHost {
       
//      parameters:
       
//          @display("p=412,70");
       
//  }
       
//  router: Router {
       
//      parameters:
       
//          @display("p=296,69");
       
//  }
        AP
: AccessPoint {
            parameters
:
               
@display("p=351,86");
       
}
        vehicularNode
: Car {
           
@display("p=239,198");
       
}
    connections allowunconnected
:
       
//accessPoint.ethg++ <--> Eth100M <--> router.ethg++;
        serverNode
.ethg++ <--> Eth100M <--> AP.ethg++;
       
// wiredHost2.ethg++ <--> Eth100M <--> router.ethg++;
}

################################My .ini file###############################

[General]
network
= testingFOG
sim
-time-limit = 400s
tkenv
-plugin-path = ../../../etc/plugins

**.addDefaultRoutes = false

**.*Node.numUdpApps = 2

**.*Node.udpApp[0].typename = "UDPEchoApp"
**.*Node.udpApp[0].localPort = 1000

**.serverNode.udpApp[*].typename = "UDPBasicApp"
**.vehicularNode.applType= "TraCIDemo11p"
**.serverNode.udpApp[1].destAddresses = "vehicularNode"
**.vehicularNode.udpApp[1].destAddresses = "serverNode"
**.*Node.udpApp[1..].destPort = 1000
**.*Node.udpApp[1..].messageLength = 100B
**.*Node.udpApp[1..].sendInterval = 1s
**.*Node.udpApp[1..].stopTime = 300s

**.initialZ = 0m
Reply all
Reply to author
Forward
0 new messages