Unable to Run <!> Error: Network '' not found,

124 views
Skip to first unread message

Artemis T.

unread,
Jan 14, 2019, 1:40:17 PM1/14/19
to OMNeT++ Users


Hello All,

I installed Omnetpp  version 5.4.1, and had a go at the sample tictoc example. I am getting an error when running the tictoc example in the samples folder. 
I googled the error, but, failed to find anything useful. I am sorry if this is a naive question, but, I would appreciate some help.

When I run it from the command, I get the following error:

opp_run -f omnetpp.ini -u Cmdenv -n .
OMNeT++ Discrete Event Simulation  (C) 1992-2018 Andras Varga, OpenSim Ltd.
Version: 5.4.1, build: 180629-5e28390, edition: Academic Public License -- NOT FOR COMMERCIAL USE
See the license for distribution terms and warranty disclaimer

Setting up Cmdenv...

Loading NED files from .:  19

Preparing for running configuration General, run #0...
Assigned runID=General-0-20190114-18:28:20-9890

<!> Error: Network '' not found, check .ini and .ned files

-------------------------------------------------
When using the IDE, I get:

OMNeT++ Discrete Event Simulation  (C) 1992-2018 Andras Varga, OpenSim Ltd.
Starting...

$ cd /home/artemis/Documents/omnetpp-5.4.1/samples/tictoc
$ tictoc -m omnetpp.ini

Version: 5.4.1, build: 180629-5e28390, edition: Academic Public License -- NOT FOR COMMERCIAL USE
See the license for distribution terms and warranty disclaimer

Setting up Cmdenv...

Loading NED files from .:  19

Preparing for running configuration General, run #0...
Assigned runID=General-0-20190114-18:31:58-10030

<!> Error: Network '' not found, check .ini and .ned files

End.

Simulation terminated with exit code: 1
Working directory: /home/artemis/Documents/omnetpp-5.4.1/samples/tictoc
Command line: tictoc -m omnetpp.ini

Environment variables:
PATH=/home/artemis/Documents/omnetpp-5.4.1/bin::/home/artemis/bin:/home/artemis/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/home/artemis/Documents/omnetpp-5.4.1/bin
LD_LIBRARY_PATH=/home/artemis/Documents/omnetpp-5.4.1/lib::
OMNETPP_IMAGE_PATH=/home/artemis/Documents/omnetpp-5.4.1/images

Thanks for all your help.
Artemis

Pavithra Thippanaik

unread,
Jan 14, 2019, 2:14:38 PM1/14/19
to omn...@googlegroups.com
Please check if you have defined your network in omnetpp.ini file

i. e. network = Tictoc1

--
You received this message because you are subscribed to the Google Groups "OMNeT++ Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to omnetpp+u...@googlegroups.com.
Visit this group at https://groups.google.com/group/omnetpp.
For more options, visit https://groups.google.com/d/optout.
--
Pavithra T
Assistant Professor
Dept of Electronics and Communication Engg
Govt SKSJT Institute
Bangalore

Artemis T.

unread,
Jan 14, 2019, 5:29:27 PM1/14/19
to OMNeT++ Users
Yes, it is defined. I am using the sample code that comes with the Omnetpp.

Tianxiang Nan

unread,
Feb 9, 2021, 10:44:29 AM2/9/21
to OMNeT++ Users
Hello,

do you have any update regarding the problem? I am a new users of omnet++ and I meet the same problem you mentioned (cannot run the tictoc sample in a cmdenc mode). Thank you in advance.

Alfonso Ariza Quintana

unread,
Feb 9, 2021, 11:25:10 AM2/9/21
to omn...@googlegroups.com

The ini file and the network definition file must be in the same directory

 

Enviado desde Correo para Windows 10

Reply all
Reply to author
Forward
0 new messages