Omnet 5.3 in installed on mac, but does not start the ide.

20 views
Skip to first unread message

Sami Ullah

unread,
Apr 26, 2018, 1:18:06 PM4/26/18
to OMNeT++ Users
Here is the log file attached,
The log files contains.
!SESSION Fri Apr 20 11:33:33 PKT 2018 ------------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2018-04-20 11:33:33.655
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.UnsupportedClassVersionError: org/eclipse/core/runtime/adaptor/EclipseStarter : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:650)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)

Please help me to solve this issue.
Thanks
1524206013633.log

Michael Kirsche

unread,
Apr 26, 2018, 2:27:41 PM4/26/18
to OMNeT++ Users
You need to update to a newer Java version for your Mac OS installation. Java SE 7 (major version 51.0) is too old, you need at least Java SE 8 to run the latest OMNeT 5.x versions.
Check the installation manual for more info.
Reply all
Reply to author
Forward
0 new messages