OMNeT++5.4.1, Veins 5.0, SUMO 1.0.0 on ubuntu 18.4, got 'Connection to TraCI server lost' error

47 views
Skip to first unread message

Shan Axida

unread,
Dec 1, 2019, 7:35:43 PM12/1/19
to OMNeT++ Users
Please help!
I have installed OMNeT++5.4.1, Veins 5.0, SUMO 1.0.0 on ubuntu 18.4.
sumo and inet4.0.0 work fine. I have tested the examples.
When I run the example in Veins, got connection to TraCI server lost error.

360截图20191202083039168.jpg


the error message on the terminal is as following

360截图20191202083215686.jpg

and the server log is 

360截图20191202083314608.jpg

please help, any solutions?



Mariam ZOUARI

unread,
Dec 2, 2019, 4:10:13 AM12/2/19
to omn...@googlegroups.com
Hello,
You should verify the sumo version and try to put the connection on port 8813 or 8873.
Good luck.

--
You received this message because you are subscribed to the Google Groups "OMNeT++ Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to omnetpp+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/omnetpp/68a8a5ea-b0fd-4b40-9a81-2d1cd4d4f900%40googlegroups.com.

Christoph Sommer

unread,
Dec 10, 2019, 1:38:33 PM12/10/19
to OMNeT++ Users Mailinglist
Shan Axida wrote:
> When I run the example in Veins, got connection to TraCI server lost error.

Your log says "Could not start SUMO (../sumo-1.0.0/bin/sumo [...]". Maybe SUMO is not installed there. Have you tried supplying an absolute path (similar to "/home/user/src/sumo-1.0.0/bin/sumo") instead?

Best,

Christoph

--
Jun.-Prof. Dr.-Ing. Christoph Sommer
Cooperative Mobile Systems (CCS Labs)
Heinz Nixdorf Institute, Paderborn University, Germany
http://www.ccs-labs.org/~sommer/

Reply all
Reply to author
Forward
0 new messages